Permission denied for mounted folder


I’m trying to setup a music server (tried both Navidrome and Jellyfin) but when trying to access my mounted network folder, I get ‘permission denied’.

FYI: In Jellyfin, it can access my movies and series mount just fine, only my music folder is a problem apparently. Navidrome logs also say permission denied.

Tried: lots of things: chown, this code:

sed -i 's/,iocharset=utf8,vers=/,iocharset=utf8,uid=dietpi,gid=dietpi,file_mode=0770,dir_mode=0770,vers=/g' /etc/fstab
umount /mnt/samba
mount -a
ls -al /mnt/samba

Searched: lots of websites, all telling the same (to do a chmod or the above code)

If I want to go into the folder as the normal dietpi user, I also get an permission denied, but with root, I can access it (maybe that’s the clue to solving it, but I don’t know how)

Hopefully someone can help me out for telling me why my movie and series mounts are perfectly accessable and the music mount (mounted in the same way, through the dietpi interface) is not.

Can you explain some more about your environment?
Just to start some basic questions:

  • On the system with the music server you did mount a network share?
    • If yes, did you mount it via NFS or via Samba?
  • Can you access the mounted files via the console?

And what filesystem does the music mount use?

I guess it’s a Samba share where media are located. Means, Samba don’t support any file system permission at all. Therefore, any command to change owner or file permission will have zero effect.

You could try to change /etc/fstab and adjust file_mode=0770,dir_mode=0770 into 777 permission to allow all user access.

The mounted share is on a Synology NAS, and I mounted it through the dietpi interface (I think it’s nfs).
Like I said, I can access it through the console, but only as root.

have a look to your /etc/fstab There you see if it is NFS or Samba

Yes, It’s NFS, not samba

Did you set no_root_squash option within your Synology NFS configuration? Can you share our /etc/fstab?

1 Like

Here’s a screenshot of my /etc/fstab

which is the folder having issues?

BTW: pls try to avoid doing screen prints. You should be able to copy everything directly from SSH Terminal.

Ok, sorry. The one having problems is the bottom one, scorpiodataMusic

can you share

ls -la /mnt/scorpiodataMusic

Problem is, it’s in a VM and I can’t SSH into it, cause although I have the correct password (works in the vm), when ssh, it says password is wrong.

Anyway, the ls code gives ‘permission denied’

Even using user root is giving access errors?

SSH login is not working for root and dietpi user?

Even using user root is giving access errors?

Only with the dietpi user, with root it gives me the file sturcture off the folder (aka ‘I can access it that way’)

SSH login is not working for root and dietpi user?

Yes, both

for investigation the issue, can you use user root pls. Can you share following?

ls -la /mnt/scorpiodataMusic

Like I said, folder sturcture

can you share as well the exact error message you have seen in Navidrome or Jellyfin? And still, following is not answered Permission denied for mounted folder - #8 by Joulinar

1 Like

Ok, apparently, that was it, the squash was set to denied, while on the movies and series folder, it was allowed. Rescanned navidrome and the music is there. Thanks all.