Odroid xu4 nextcloud freeze/stuck during install nextcloud ( Problem Fixed )

Thanks Michalng everything seems to work right now , just fresh install back to my eMMC and i’ll move user_data to ssd soon .

I found out i have to do ’ apt install haveged ’ first then install nextcloud otherwise i will stuck on ’ chown -R www-data:www-data /var/www/nextcloud /mnt/dietpi_userdata/nextcloud_data ’

[  OK  ] DietPi-Software | phpenmod ctype curl dom gd intl mbstring pdo_mysql posix simplexml xmlreader xmlwriter zip fileinfo opcache apcu redis exif
[ INFO ] DietPi-Software | Apply PHP override settings for Nextcloud.
[  OK  ] DietPi-Software | phpenmod dietpi-nextcloud
[ INFO ] DietPi-Software | Lighttpd webserver found, enabling Nextcloud specific configuration.
[  OK  ] DietPi-Software | Desired setting in /etc/lighttpd/lighttpd.conf was already set:      "mod_access",
[  OK  ] DietPi-Software | Added setting        "mod_setenv", to /etc/lighttpd/lighttpd.conf after line         "mod_indexfile",
[  OK  ] DietPi-Software | cd /tmp/DietPi-Software
[  OK  ] DietPi-Software | curl -sSfL https://raw.githubusercontent.com/MichaIng/DietPi/master/.conf/dps_114/lighttpd.nextcloud.conf -o lighttpd.nextcloud.conf
[  OK  ] DietPi-Software | mv lighttpd.nextcloud.conf /etc/lighttpd/conf-available/99-dietpi-nextcloud.conf
[  OK  ] DietPi-Software | lighty-enable-mod rewrite dietpi-nextcloud
[  OK  ] DietPi-Software | lighty-enable-mod dietpi-dav_redirect
[  OK  ] DietPi-Software | systemctl restart mariadb
[  OK  ] DietPi-Software | systemctl restart redis-server
[  OK  ] DietPi-Software | mkdir -p /mnt/dietpi_userdata/nextcloud_data
[  OK  ] DietPi-Software | chown -R www-data:www-data /var/www/nextcloud /mnt/dietpi_userdata/nextcloud_data

just freeze on

 [  OK  ] DietPi-Software | chown -R www-data:www-data /var/www/nextcloud /mnt/dietpi_userdata/nextcloud_data

Probably it just takes a while, how long did you wait? Was it a fresh Nextcloud install or are there already files in /mnt/dietpi_userdata/nextcloud_data? And did you move DietPi userdata to an external drive?

waited like 30 mins then freeze , tried emmc and microsd even plugin ssd then transfer user_data still stuck on there

Edit : tried many way fresh install to emmc and fresh install microsd , both not work , then i move dietpi user_data to ssd still stuck on chown -R www.-data:www.data , i restarted the device and then screen pop up and ask me to change the password again which i already did after 1st time updated

Ah, can you try the following:

mkdir /etc/systemd/system/haveged.service.d
echo -e '[Service]\nSystemCallFilter=uname' > /etc/systemd/system/haveged.service.d/dietpi.conf
apt update
apt install haveged
dietpi-software install 114

When you say you update to Linux 5.4, you mean that you flashed our new image?

Ok i’ll try i took a screenshot

updated kernel then flash new bullseye image , actually i have no problem before bullseye with kernel 4.1.4 , after updated i have so many problem , im looking for a image before bullseye but too bad it’s already removed from dietpi.com

it seems fixed and nextcloud is up now but i got this , i’m current installed on micro sd for testing , should i fresh install to eMMC with that command you gave me or should i move dietpi user_data to ssd before install nextcloud ?

I got vdd_Idol12: disabling on login screen

root@DietPi:~# Existing Nextcloud Lighttpd configuration found, will preserve the old one   │
-bash: Existing: command not found
root@DietPi:~# │ and save the new one for review and comparison to:                           │
-bash: │: command not found
root@DietPi:~# │ /etc/lighttpd/conf-available/99-dietpi-nextcloud.conf.dietpi-new             │
-bash: │: command not found

Let me first recreate the image with haveged installed in the first place. I actually thought we verified that the hardware random generator is working with the new kernel, seems we verified wrong.

Just in case, can you check:

systemctl status rngd

Optimum would be to flash the image to eMMC and move DietPi userdata to SSD.

Where did you get those three failing commands from? Those are no valid command but output done during Nextcloud installation :thinking:.

root@DietPi:~# systemctl status rngd
● rngd.service - Start entropy gathering daemon (rngd)
     Loaded: loaded (/lib/systemd/system/rngd.service; enabled; vendor preset: enabled)
     Active: inactive (dead) since Sun 2022-05-29 21:17:07 PDT; 2h 17min ago
       Docs: man:rngd(8)
   Main PID: 366 (code=exited, status=0/SUCCESS)
        CPU: 407ms

May 29 21:17:02 DietPi systemd[1]: Started Start entropy gathering daemon (rngd).
May 29 21:17:07 DietPi rngd[366]: too many FIPS failures, disabling entropy source
May 29 21:17:07 DietPi rngd[366]: No entropy sources working, exiting rngd
May 29 21:17:07 DietPi systemd[1]: rngd.service: Succeeded.

Also if i don’t run this command you gave me before nextcloud , i will stuck @

mkdir /etc/systemd/system/haveged.service.d
echo -e '[Service]\nSystemCallFilter=uname' > /etc/systemd/system/haveged.service.d/dietpi.conf
apt update
apt install haveged
dietpi-software install 114
DietPi-Software | chown -R www-data:www-data /var/www/nextcloud /mnt/dietpi_userdata/nextcloud_data

Yes correct, we don’t offer older images anymore by purpose.

Okay so indeed rngd still doesn’t work. I’ll generate a new image with haveged pre-installed on a few hours.

Thanks Michalng and please read these post i have already explain the problem and
user ‘andoru’ having the same boot up problem , If xu4 fails to boot up new dietpi image
then ubuntu 20.04 or 22.04 won’t boot up too . only 18.04 works