odroid XU4 boot error after kernel upgrade

well I’m quiet unlucky with my XU4 :frowning:

Using v157 and upgraded the kernel to 3.10.106+ (I think. I’m using Yunohost with it and it upgraded everything automatically)
Now the XU4 doesn’t boot anymore
Exchanging the boot.ini, a recommendation from fourdee on twitter, with this: https://raw.githubusercontent.com/Fourdee/DietPi/testing/boot_xu4.ini
wasn’t successful.

I already had a similar issue two months ago and replaced a number in the boot.ini file and after another try to boot the odroid, I reverted that change.
Both didn’t help
here the topic: https://dietpi.com/forum/t/latest-xu4-kernel-seems-to-break-install/1418/1

I’m pretty sure, that another uboot-upgrade is the root cause of this issue. I had that package a long time marked as hold (apt), but tried it two or three weeks ago and everything went fine after upgrading it - maybe there was something I missed.

Connecting the XU4 via HDMI doesn’t output anything, so I cannot share a bootlog or similar.

And no - I don’t have a backup. No backup - no mercy - I know, but hopefully there’s a fix I can try before starting from scratch :slight_smile:

Shameless selfbump - does nobody have an idea?

https://dietpi.com/forum/t/odroidxu4-lan-not-working-after-kernel-update-to-158/1609/1

thank you for your hint, but this time this doesn’t work - that was the fix mentioned in my first post - second link…
The behavior doesn’t change and it’s still hanging. (the fan is constantly rotating, the harddrive leds are blinking for 10 sec or so, after that they shutdown, the blue and yellow leds on the side are blinking too for a bit)

I’ve to add, that I have a cloudshell 2 with two harddrives in a RAID1, booting from the SD but the filesystem itself is copied onto that harddrives.
Do you think I have to change there something as well?
Maybe this is the reason, why I can’t find the file xynos5422-odroidxu4.dtb in boot - but the odroidxu3.dtb isn’t on the SDcard too.

Here’s my boot.ini located on boot/boot.ini

ODROIDXU-UBOOT-CONFIG

# U-Boot Parameters
setenv initrd_high "0xffffffff"
setenv fdt_high "0xffffffff"

# Mac address configuration
setenv macaddr "00:1e:06:61:7a:72"

#------------------------------------------------------------------------------------------------------
# Basic Ubuntu Setup. Don't touch unless you know what you are doing.
# --------------------------------
setenv bootrootfs "console=tty1 root=UUID=a4f12232-1670-43f4-8eca-49bfbe4d01ee rootwait ro fsck.repair=yes"

# --- Screen Configuration for HDMI --- #
setenv videoconfig "drm_kms_helper.edid_firmware=edid/1920x1080.bin"

# --- HDMI / DVI Mode Selection ---
# ------------------------------------------
# - HDMI Mode
setenv vout "hdmi"
# - DVI Mode (disables sound over HDMI as per DVI compat)
# setenv vout "dvi"

# --- CPU Governor Setup ---
# - DietPi will override this setting to user configured in dietpi-config > Performance Options > CPU gov.
setenv governor "performance"

#------------------------------------------------------------------------------
#
# HDMI Hot Plug detection
#
#------------------------------------------------------------------------------
#
# Forces the HDMI subsystem to ignore the check if the cable is connected or
# not.
# false : disable the detection and force it as connected.
# true : let cable, board and monitor decide the connection status.
#
# default: true
#
#------------------------------------------------------------------------------
setenv HPD "true"

#------------------------------------------------------------------------------
#
#  TMDS data amplitude control.
#
#------------------------------------------------------------------------------
#
#  1LSB corresponds to 20 mVdiff amplitude level.
#  tx_amp_lvl : 0 = 760 mVdiff(Min), 31 = 1380 mVdiff(Max)
#
#  Hardkernel default hdmi_tx_amp_lvl = 31(1380 mVdiff);
#------------------------------------------------------------------------------
setenv hdmi_tx_amp_lvl  "31"

#------------------------------------------------------------------------------
#
#  TMDS data amplitude fine control for each channel.
#
#------------------------------------------------------------------------------
#
#  1LSB corresponds to 20 mVdiff amplitude level.
#  tx_lvl : 0 = 0 mVdiff(Min), 3 = 60 mVdiff(Max)
#
#  Hardkernel default
#      hdmi_tx_lvl_ch0 = 3, hdmi_tx_lvl_ch1 = 3, hdmi_tx_lvl_ch2 = 3,
#------------------------------------------------------------------------------
setenv hdmi_tx_lvl_ch0      "3"
setenv hdmi_tx_lvl_ch1      "3"
setenv hdmi_tx_lvl_ch2      "3"

#------------------------------------------------------------------------------
#
#  TMDS data pre-emphasis level control.
#
#------------------------------------------------------------------------------
#
#  1LSB corresponds to -0.45dB emphasis level except for 1
#  tx_emp_lvl : 0 = 0 db(Min), 1 = -0.25 db, 2 = 0.7 db, 15 = -7.45 db(Max)
#
#  Hardkernel default hdmi_tx_emp_lvl = 6 (-2.50 db);
#------------------------------------------------------------------------------
setenv hdmi_tx_emp_lvl      "6"

#------------------------------------------------------------------------------
#
#  TMDS clock amplitude control.
#
#------------------------------------------------------------------------------
#
#  1LSB corresponds to 20 mVdiff amplitude level.
#  clk_amp_lvl : 0 = 790 mVdiff(Min), 31 = 1410 mVdiff(Max)
#
#  Hardkernel default hdmi_clk_amp_lvl = 31 (1410 mVdiff)
#------------------------------------------------------------------------------
setenv hdmi_clk_amp_lvl     "31"

#------------------------------------------------------------------------------
#
#  TMDS data source termination resistor control.
#
#------------------------------------------------------------------------------
#
#  tx_res :
#      0 = Source Termination OFF(Min), 1 = 200 ohm, 2 = 300 ohm, 3 = 120 ohm(Max)
#
#  Hardkernrel default hdmi_tx_res = 0 (Source Termination OFF)
#------------------------------------------------------------------------------
setenv hdmi_tx_res      "0"

#------------------------------------------------------------------------------

setenv hdmi_phy_control "hdmi_tx_amp_lvl=${hdmi_tx_amp_lvl} hdmi_tx_lvl_ch0=${hdmi_tx_lvl_ch0} hdmi_tx_lvl_ch1=${hdmi_tx_lvl_ch1} hdmi_tx_lvl_ch2=${hdmi_tx_lvl_ch2} hdmi_tx_emp_lvl=${hdmi_tx_emp_lvl} hdmi_clk_amp_lvl=${hdmi_clk_amp_lvl} hdmi_tx_res=${hdmi_tx_res} HPD=${HPD} vout=${vout}"

# Load kernel, initrd and dtb in that sequence
fatload mmc 0:1 0x40008000 zImage
fatload mmc 0:1 0x42000000 uInitrd
fatload mmc 0:1 0x44000000 exynos5422-odroidxu4.dtb

# set FDT address
fdt addr 0x44000000

if test "${cecenable}" = "false"; then fdt rm /cec@101B0000; fi
if test "${disable_vu7}" = "false"; then setenv hid_quirks "usbhid.quirks=0x0eef:0x0005:0x0004"; fi

# final boot args
setenv bootargs "${bootrootfs} ${videoconfig} smsc95xx.macaddr=${macaddr} governor=${governor} ${hdmi_phy_control} ${hid_quirks}"
# drm.debug=0xff"
# Boot the board
bootz 0x40008000 0x42000000 0x44000000

Something appears to be very wrong in DietPi XU4 world. I tried all day yesterday, using 2 different boards, to download the latest DietPi image and boot up. Absolutely no luck doing something I’ve done dozens of times before. The board never powered off as it was supposed to, and the blue light never turned off as expected. Both red and blue lights blinked as well as the ethernet yellow lights but no love. Nothing ever appeared on my hdmi monitor except for repeated occasional flashing on/off. After switching every conceivable component (cables, monitor, SDs, checking voltages, trying emmc, etc.) I have gotten nowhere. Thinking maybe something in my environment here was a problem, I tried the C2, a Pine 64 and a Pi 3 – with no boot problems.

I also had no xynos5422-odroidxu4.dtb in boot. In Allamur’s example below he also didn’t show that file in his boot, but it appeared in his boot.ini?

We need some assistance here soon please.

Have you tried the boot.ini I’ve linked to in post 1?
Does it work for you?

I just did. No luck (after waiting the obligatory 5 minutes). Now I am going to go into dietpi/dietpi-config and make the suitable changes there and try. I wanted to do only the root.ini substitution first. Give me 10 minutes…

Umm, I think that is the wrong config.file :blush: It appears that gets generated when the user runs dietpi-config program and is referenced upon reboot. So I am redirecting myself to the boot level config (.txt)… Let’s hang in here together until we, one way or another, get our XU4s and my HC1 working again. BTW, I am in Thailand, and you?

Well, another day of getting nowhere. :frowning: Fourdee PLS give us a hand! Or whomever! This isn’t any fun anymore.

Does anybody have a working installation?
This may be a way to find out what’s wrong with ours.

Porterdon - I’ve just installed the 154 image on an 8 GB SD card and working fine here.

Maybe your image was corrupted? Try downloading it again?

John

Will do right now…thanks…

I’ve done that many times, but did again. Same. No boot.

Hmm. Found an old post:





Solved: Dead after: pacman -Suy, included Firmware Update

Postby lidroid » Fri Jun 05, 2015 6:47 pm
Hi Forum,

i updated yesterday my Arch Linux it included a Firmware update, and after the reboot i get no Display Output, only glowing red and blinking blue led.
Any chance to get it back running?

pacman.log:

[2015-06-04 22:45] [ALPM] upgraded linux-firmware (20150206.17657c3-1 → 20150511.8e18132-1)


Re: Dead after: pacman -Suy, included Firmware Update

Postby Hominidae » Sat Jun 06, 2015 3:04 am
I also thought in the same direction as Ricardona.
It is indeed hard to figure out what your problem is from what you gave away.

A blinking blue LED, IMHO does mean it has indeed booted and the kernel is up an running.
Maybe you don’t have any UI and no network (to ssh into it)?
Do you have a UART adapter available?

…I did an update on my ALARM C1 box only yesterday and all is fine after reboot (no X installed, only plain ALARM).
If you happen to have no network…any traces from your router’s side?


Re: Solved: Dead after: pacman -Suy, included Firmware Updat

Postby lidroid » Sun Jun 07, 2015 4:40 pm
Thank you Ricardona,

Blinking blue LED == running OS, i tried it again.
It was the same Problem! my monitor was not that nice to say out of sync. Only with a different one i was able to run at 720p with dvi.
The root cause was a glitch in the router, he gave me no ip, but worked again after a reboot.


I’ll be looking into this…

Have you tried to upgrade dietpi and the kernel?
if I reinstall it, it’s working as well, but I won’t reinstall it, because of my apps and settings I have to reinstall as well == to much work.

Yes upgraded to v 158 and did kernel upgrade to the latest in the 3 series - worked fine. Why not try this on a spare SD card?

Which kernel were you hoping to upgrade to - the 3 series or 4.9?

John

John, I’m not fussy. Any kernel which will actually allow me to BOOT!

OK, I downloaded V154 and tried to boot, lights happily(?) flashing away like it was Christmas – red, blue, yellow ethernet but no booting into ‘Joy to the World’. No monitor display. Nothing. Nada, zip, nichts, rien, niente, and in Thai: ไม่มีอะไร.

Pulled out the SD and went into config and uncommented to set:

hdmi_safe=1
hdmi_force_hotplug=1 (not clear if I needed to do this)
config_hdmi_boost=4 (sure, why not?)
(didn’t touch the HDMI modes, as if I had a clue)

Then went into boot, uncommented to set:

setenv vout “hdmi”


Then I pulled out the SD, inserted it into the XU4, plugged in the HDMI and power jack… crossed fingers … and … Ta Daa! :wink:

:thinking: :open_mouth: :imp:

… SPLAT!

Dear Mr. Hardkernel:

I’ll be taking a few days off. Need a little break out of town… in Raspberry Pi land.

Please carry on. :nerd:

Yours faithfully,

Don

P.S. Please send money. $36 would be perfect. :sunglasses:

If it doesn’t boot with a freshly flashed SD card then maybe the XU4 has a fault? Or inadequate power supply? Faulty SD?

Have you tried installing anothter distro?

John



Like I stated in my initial post → 3.1.106+ on version 157.
And like I said before - The problem is gone if I reinstall my whole system, but this is no option now (until I really have to, if there’s no fix available)

The fixes PorterDon recommends don’t work - I still don’t get any signal out of it to give you some more information (If there’d be some kind of bootlog I’d be so glad to share it with you to get this thing fixed)

The powersupply works, it’s the official powersupply of the cloudshell 2 which worked until I rebooted it and if I use another SD-Card or even the same card (made a clone before and reinstalled the system on that same card) it’s working normally and I can connect via SSH.
So the SD-Card, the power supply, the network or the XU4 itself is not the issue.

Can you post your boot.ini and is there something in your /rootfs/Dietpi folder? Can you just make an image of your working SD-Card so I can compare the differences? That would be really nice and I’m posting the issue on github if I find the rootcause.

EDIT: Hell I even make a video now to show you what’s going on:
Rw7NwhE7FrQ

The Solution:

The firmware file exynos-blabla.dtb was simply missing!
I installed dietpi again on another card copied that file into the boot directory of the other card and it’s booting!

Maybe the uboot or kernel upgrade removed the old xu3.dtb file but didn’t install the new xu4.dtb file.