Node-red will not install. GLIBCXX_3.4.26 not found

While I try to install node-red with dietpi-software, I´ll get the error: node: /usr/lib/arm-linux-gnueabihf/ version `GLIBCXX_3.4.26’ not found (required by node)

I have made a bugreport with the reference code: b1439634-73e4-4597-9c72-ce04f8d3779f

Can anyone help me with the bug, or access the bug report somewhere?

Thanks in advance

Why not filling out the trouble shooting template? Access to the bug report is strictly limited to a very small number of people.

Probably your Debian version is to old?


  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname -a
  • Architecture | dpkg --print-architecture
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)

EDIT: The search in the forum yields the following result Updating NodeRed breaks installation with node/glibc error - #2 by Joulinar

yes, I am not so familiar with the reporting system for errors. Please forgive me for that. Here is the data you are requesting:

root@Cloud:~# cat /boot/dietpi/.version
root@Cloud:~# echo $G_DISTRO_NAME $G_RASPBIAN
buster 1
root@Cloud:~# uname -a
Linux Cloud 5.10.103-v7l+ #1529 SMP Tue Mar 8 12:24:00 GMT 2022 armv7l GNU/Linux
root@Cloud:~# dpkg --print-architecture
root@Cloud:~#  echo $G_HW_MODEL_NAME
RPi 4 Model B (armv7l)

The problem seems to occur when node-red is to be installed. Node will be installed fine!?

Step: Installing Node-RED: tool for wiring devices, APIs and online services

[ INFO ] DietPi-Software | APT install python3, please wait...
Reading package lists...
Building dependency tree...
Reading state information...
python3 is already the newest version (3.7.3-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[  OK  ] DietPi-Software | APT install python3
[  OK  ] DietPi-Software | mkdir -p /mnt/dietpi_userdata/node-red
[  OK  ] DietPi-Software | usermod -aG dialout,gpio,i2c,spi -d /mnt/dietpi_userdata/node-red -s /usr/sbin/nologin nodered
[  OK  ] DietPi-Software | eval echo 'nodered ALL=NOPASSWD: ALL' > /etc/sudoers.d/nodered
[  OK  ] DietPi-Software | chown -R nodered:nodered /mnt/dietpi_userdata/node-red
[  OK  ] DietPi-Software | cd /mnt/dietpi_userdata/node-red
[ INFO ] DietPi-Software | sudo -u nodered npm i --no-audit node-red, please wait...
node: /usr/lib/arm-linux-gnueabihf/ version `GLIBCXX_3.4.26' not found (required by node)
[FAILED] DietPi-Software | sudo -u nodered npm i --no-audit node-red

I found this in my folder /usr/lib/arm-linux-gnueabihf
lrwxrwxrwx 1 root root 19 Apr 16 2019 ->

Therefore I think I need the lib with version .26? But both are from the Dietpi system. The libs and also the installation script for node-red was called via dietpi-software!

Thanks in advance

You are running an old Debian Buster system. Have a look into our upgrade guide to move ahead to Debian Bullseye / Bookworm

There are also some hacky workarounds available, if you REALLY need to stay on Debian Buster (which I not recommend):

We will drop Buster support at the end of this year latest. Therefore upgrading to Bullseye is highly recommended.

I think my problem has another problem. By the last update probably the file libstdc++ has been shot and has now a length of 0 byte. I can’t do any updates because I always get the error: apt-get: error while loading shared libraries: /usr/lib/arm-linux-gnueabihf/ file too short
Where can I download the file one by one and then replace it via FTP or USB stick to the original location, or is there another command that can fix this?
Thanks a lot

Do you have a backup of your system?

Unfortunately no, I know that’s stupid! I do not have much on the system yet, but I would have to reinstall my RAID array. I’m not so fit there and need quite a bit of time for it?! But I guess it boils down to that?

are you still on Debian Buster or did you already started migration to Bullseye? Can you share

ls -la /usr/lib/arm-linux-gnueabihf/ | grep libstdc
root@Cloud:~# ls -la /usr/lib/arm-linux-gnueabihf/ | grep libstdc
lrwxrwxrwx  1 root root       19 Apr 16  2019 ->
-rw-r--r--  1 root root        0 Jul 31 11:32

this one to be replace. Try the attached file. Copy it to your system and remove the file extension .log

Thank you very much, I will report back if it worked. Still need something for it.
I’ll be in touch!
Thanks again

I have imported the file via USB stick. Everything worked great. Then I was able to do a dietpi backup and after that I did the manual update to bullseye per instructions (DietPi - How to upgrade to "Bullseye" - DietPi blog). Everything worked great.
Thanks again, you are really the best!

hello! can you share the file? I have the same issue but don’t see the file. Thanks!

There is no file, you need to upgrade the Debian version as described above.

Or what exactly is your issue?

I can’t upgrade right now so I need to use current OS version, just need the file you wrote earlier:

I think this can help me too.

Before you copy any file, you should share a few error messages. Or have you already checked whether your file is empty? Btw, the file is part of every image, and you can extract it yourself.

My file is not zero, but I have the same error. The case is the same I think. So the solution is the same too, I hope. Is there a link to the file anywhere or not? Just want to try that way… Upgrade the system is not my choice for now.

The case above was about a corrupted file without content. Therefore it was replaced. Your case might be different as your file still exists.

Again my request to share more information and some error messages. And pls don’t forget to share your system information. A template can be found above as well.