New DietPI won't even start?


I downloaded the Raspberry Pi image, specifically “DietPi_RPi-ARMv6-Stretch”

I have burned it now 3 times with Balena Etcher to a 32GB MicroSD and not once does my Raspberry Pi 4 actually boot up and connect to my network (via Ethernet). Raspbian on the other hand works no problems, first time every time. I’ve waited up to 30 minutes but the Pi never seems to do anything.

I’ve checked my router and it never shows the Pi as a part of the network. The light on the Pi remains red (no green ‘working’ flash) and the Ethernet port shows no activity either.

I don’t have a micro HDMI nor a monitor to test with a screen to see what is happening.
But what I want to do is obviously have DietPi set itself up automatically and enable SSH the same as Raspbian would…

I have an official AC adapter for my Pi and the MicroSD has no problems with Raspbian. I have also checked and verified img checksum. Neither of these should be the problem.

Here’s my dietpi file (have tried with static I.P. on/off):

# - Modifications to /boot/dietpi.txt will not be preserved on reboot.
# - Please ensure you edit from the DietPi-RAMdisk location: /DietPi/dietpi.txt

# NB: This is intended for advanced users, unless you know what you are doing, do not edit this file. Please use the DietPi programs instead.
# NB: Do not remove uncommented lines, as the items are scraped by DietPi programs, on demand.

# D I E T - P I
# DietPi-Automation settings, applied on 1st boot of DietPi only, ONCE!

##### Networking Options #####

#    If both Ethernet and WiFi are enabled, WiFi will take priority and Ethernet will be disabled.
#        1=enabled

#    If using WiFi, please edit dietpi-wifi.txt to pre-enter credentials.

#    Enter your Static Network details below, if applicable.

#    Hostname

#    Force ethernet speeds
#        NB: This is mainly aimed at Pine A64's which may have an HW issue that causes unstable 1Gbit link.
#        0=automatic speed | 10 = 10mbit, 100 = 100mbit etc

##### Misc Options #####

#    Size of swapfile to generate (MB)
#        0=Disabled | 1=auto (2GB-RAM = size) | 2+=manual
#        Optional swapfile location

# Unmask (enable) systemd-logind service, which is masked by default on DietPi

##### Software Automation Options #####

#    Fully automate the installation
#        1=Automated installation with no user inputs.
#        It is HIGHLY recommended to also set CONFIG_BOOT_WAIT_FOR_NETWORK=2, to force infinite wait for network connection during boot, preventing no connection errors due to timeout.

#    Global Password to be applied for the system
#        Requires AUTO_SETUP_AUTOMATED=1
#        Affects user "root" and "dietpi" login passwords, and, all software installed by dietpi-software, that requires a password
#        eg: MySQL, Transmission, Deluge etc.
#        WARN: Passwords with the any of the following characters are not supported: \"$
#        WARN: Do NOT change this entry after 1st run setup of DietPi has been completed. It is always scraped by dietpi-software.

#    DietPi-Software to automatically install. | requires AUTO_SETUP_AUTOMATED=1
#    For a list of software index's (ID's), run '/DietPi/dietpi/dietpi-software list'
#    No limit on number entries, add as many as you need and uncomment the line.
#    DietPi will automatically install all pre-reqs (eg: ALSA/XSERVER for desktops etc)
#    - Examples:
#AUTO_SETUP_INSTALL_SOFTWARE_ID=23    #will install Desktop LXDE
#AUTO_SETUP_INSTALL_SOFTWARE_ID=74    #will install LAMP webserver stack
#AUTO_SETUP_INSTALL_SOFTWARE_ID=44    #will install Bittorrent transmission

#    DietPi-Software Choice System
#    SSH Server Selection:
#        0=none
#        -1=dropbear
#        -2=opensshserver

#    File Server Selection:
#        0=none/manual
#        -1=proftp
#        -2=samba

#    Logging Mode Selection:
#        0=none/manual
#        -1=ramlog 1h clear
#        -2=ramlog 1h save clear
#        -3=logrotate + rsyslog
#    RAMlog max tmpfs size (MB). 50MB should be fine for single use. 200MB+ for heavy webserver and access log use etc.

#    Webserver Preference Selection:
#    NB: This will get ignored, if you have manually selected any WEBSERVER_Stack.
#        0=Apache2
#        -1=Nginx
#        -2=Lighttpd

#    DietPi-Autostart | Requires AUTO_SETUP_AUTOMATED=1
#    After installation is completed, which program should the system boot to?
#        0=Console 7=Console+auto root login | 1=Kodi 2=Desktops (LXDE/MATE etc) 5=DietPi-Cloudshell 6=Uae4ARM (Fastboot) 8=Uae4ARM (standard boot) 9=dxx-rebirth

#    Language/Regional settings | Requires AUTO_SETUP_AUTOMATED=1
#        Timezone eg: Europe/London America/New_York | Full list (TZ*):
#        Locale eg: en_GB.UTF-8 / en_US.UTF-8 etc. One entry ONLY.
#        Keyboard Layout eg: gb us de fr

#    Custom Script (pre-networking and pre-DietPi install) | Runs before DietPi installation and networking
#        Allows you to automatically execute a custom script before networking and DietPi installation is started
#        Option 1 = Copy your script to /boot/ and it will be executed automatically.
#        NB: Executed script log /var/tmp/dietpi/logs/dietpi-automation_custom_prescript.log

#    Custom Script (post-networking and post-DietPi install) | Runs after DietPi installation is completed
#        Allows you to automatically execute a custom script at the end of DietPi installation.
#        Option 1 = Copy your script to /boot/ and it will be executed automatically.
#        Option 2 = Host your script online, then use AUTO_SETUP_CUSTOM_SCRIPT_EXEC= , it will be downloaded and executed automatically. | 0=disabled
#        NB: Executed script log /var/tmp/dietpi/logs/dietpi-automation_custom_script.log

#Disable HDMI (and GPU/VPU where supported) output for supported devices:
#	RPi | Odroid C1 | Odroid C2

# D I E T - P I
# DietPi-Config settings

#Cpu Governor | ondemand | powersave | performance | conservative

#CPU Frequency Limits
#    NB: Intel CPU's use a percentage value (%) from 0-100 (eg: 55)
#    NB: All other devices must use a specific MHz value (eg: 1600)
#    Limit the MAX CPU frequency for all cores | Disabled=disabled
#    Limit the MIN CPU frequency for all cores | Disabled=disabled

#    Disable Intel-based turbo/boost stepping. This flag should not be required, setting <100% MAX frequency should disable Turbo on Intel CPU's.

#Min value 10000 microseconds (10ms)

#sampling rate * down factor / 1000 = Milliseconds (40 = 1000ms when sampling rate is 25000)

#Proxy settings | System-wide proxy settings
#    NB: Do not modify, you must use dietpi-config > "Network Options: Adapters" to apply

#Delay boot until network is established: 0=disabled | 1=10 second wait max (default) | 2=infinite wait

#Connection timeout, before DietPi G_CHECK_URL assumes the URL is dead. Increase if you have a "flaky" connection or slow DNS resolver.
#    NB: Set this to "0" to allow unlimited time, however this is not recommended to avoid unlimited hanging background scripts, e.g. daily DietPi update check.
#Connection attempts with above timeout each, before DietPi G_CHECK_URL is giving up and prompts an error.
#    NB: Set this to "0" to disable URL checking completely, however this is not recommended to avoid harder to debug follow-up errors during APT and download attempts.

#DietPi checks for updates (allows dietpi to check for updates on a daily basis and boot using a <1kb file download.)
#    Optional: Automatically update DietPi when updates are available. | requires CONFIG_CHECK_DIETPI_UPDATES=1

#NTPD Update Mode: 0=disabled | 1=boot only | 2=boot + daily | 3=boot + hourly | 4=Daemon + Drift

#WiFi country code. 2 character value (eg GB US DE JP):

#Serial Console: Set to 0 if you do not require serial console.


#LCD Panel addon
#    NB: Do not modify, you must use dietpi-config to configure/set options


#Prefer IPv4 with APT and wget, NB: This has no effect if IPv6 is disabled anyway!

#APT mirrors which are applied to /etc/apt/sources.list | Values here will also be applied during 1st run setup
#    Raspbian =
#    Debian =

#NTPD mirror, applied to /etc/ntp.conf
#    For a full list, please see
#    Please remove the initial integer and full stop from the value (removing 0.). eg:

# D I E T - P I
# DietPi-Software settings
#Enter your write API key here. It will be applied automatically during EmonPi/Hub installation.
#    eg: SOFTWARE_EMONHUB_APIKEY=b4dfmk2o203mmxx93a

#VNC Server Options

#Optional username for ownCloud/Nextcloud admin account, the default is 'admin'. Applied during installation.

#Optional data directory for ownCloud, default is '/mnt/dietpi_userdata/owncloud_data'. Applied during installation.
#    This option is for advanced users. For full compatibility, please keep this options defaults, and, use dietpi-drive_manager to move the DietPi user data location.

#Optional data directory for Nextcloud, default is '/mnt/dietpi_userdata/nextcloud_data'. Applied during installation.
#    This option is for advanced users. For full compatibility, please keep this options defaults, and, use dietpi-drive_manager to move the DietPi user data location.

#Wifi Hotspot
#    minimum of 8 characters

#Xorg options
#	DPI 96(default) 120(+25%) 144(+50%) 168(+75%) 192(+100%)

#Chromium Options

# D I E T - P I
# Dev settings

# D I E T - P I
# Settings, automatically added by dietpi-update

P.S. It was a real pain to pass the verification to register on the forums here because I couldn’t even boot my Pi in order to find out the team members to answer the question. I had to hunt around on the internet for 30 minutes to find the answer… Consider changing that, it prevents people who can’t even get into their install from being able to register and ask for help.

I’m sad that 26 people read this but no one replied.

Well I spent 25 euros today and I got an HDMI to Micro HDMI adapter so I could actually plug my Pi into a TV at work.

Long story short. The official image: DietPi_RPi-ARMv6-Stretch - it does not boot at all. Doesn’t matter if it’s burned with Balena, Win32DiskImager, Rufus, what-ever. It won’t boot. I have tried modifying every flag in the dietpi.txt file and I have also left it alone and tried on two different networks. It won’t start, it won’t even engage the HDMI and show me an error. Basically the Pi can’t detect the OS at all.

The 'experimental image however: DietPi_v6.25_RPi-ARMv6-Buster - it works fine. Boots first time, with the requested flags and takes about 90 seconds to be ready.

I have no idea why the official image doesn’t boot despite that it’s meant to be the most stable one. Unfortunately there’s also no log to share because the OS doesn’t even start (for the “stable” version). Not sure if this is an issue specific to the Raspberry Pi 4 but it didn’t work for me.

I also tried 2 different MicroSDs and after something like 16 attempts, I worked out that it has nothing to do with what card I use. That official stable image, the first one. It doesn’t boot.

For now I’ll use the experimental image and see how that goes, hopefully it’s not too unstable or anything. /thread.

Sorry for the late reply. The Stretch image we provided was not yet Raspberry Pi 4 compatible. This requires a new kernel + bootloader version and Raspbian Buster.
We provided an experimental Buster image that was RPi4 compatible.

Sorry for not providing this information earlier on the download page.

But the experimental image has now replaced the old Stretch image, I updated our download page accordingly. Please re-download:
Report back if you still face issues, although there are already hundreds of successful RPi4 installs now, which prove it functional: