network storage related questions..

I have a odroid c2 which I used as a media device with kodi connected to a external hdd but i recently got a c4 for that… would the c2 be able to run a samba share ontop of pihole and a torrent application? I know the c2 has a slower usb but I have a pretty slow internet connection so its 30ish mb/s speed limit will probably top out my connection while torrenting which is around half the speed.(10 to 12 mb/s) most of the media i would be sharing through samba would be around just below hd around 720p. thanks for any help or suggestions. :slight_smile:

I guess something you would need to try out yourself to see if it will fit your need.

uh when you go to mount the hdd does it matter what you call the mount point or do you need to leave it default?

Using drive manager it could be everything in /mnt/

uh I got a few errors…heres what it says. can you tell what i did wrong? reading a few posts and im still not sure.

[FAILED] Samba mount failed with the following error output:                 │
│                                                                              │
│ mount error(22): Invalid argument                                            │
│ Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)                 │
│ mount error(2): No such file or directory                                    │
│ Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)                 │
│ mount error(2): No such file or directory                                    │
│ Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)                 │
│ mount error(2): No such file or directory                                    │
│ Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)                 │
│ Retrying with upper case share name                                          │
│ mount error(6): No such device or address                                    │
│ Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

You tried to mount an existing share from another samba server on DietPi. But the share you specified is not existing.

However I thought you tried to setup samba on DietPi? If this was the case you choose wrong option. To setup samba server on DietPi, you would need to use dietpi-software and select Samba as file server option to have it installed.

uh samba was already installed I was trying to set up a external as a share. its set up the emmc as the share…but now I messed something up and nothing is being shared. also thats cool you can mount drives from other samba shares on a different system. der didnt know that. :stuck_out_tongue:

You would need to manually edit smb.conf file, to create new shares or to manage existing once.

got it working the thing I messed up was not logging in as root and forgeting a number in the mnt point name. works good now. now I just need to figure out how to maybe encrypt it and then maybe install pihole. thanks a bunch. getting 22-24mb/s on samba. :slight_smile:

PiHole could be simply installed using


For encryption we know about a working method for RPi and you could have a look to

Not sure on a C2 if it working similar.

hmm rutorrent keeps freezing and its plugins are crashing. deluge will not let me log in to its webui and transmission wont download in a stable way. should i try to reinstall dietpi? samba seems to works fine though.

probably you need to check memory usage how it goes.

free -m

um now ive wiped my sdcard and im now unable to reinstall dietpi as it says it cant handshake or something… its after i log in with root/dietpi then it says a bunch of stuff that goes by to quick and asks me if i want to retry something that failed…

It is impossible to help you, if you don’t share real error message or logs.

it didnt give me an error it just asked me to retry apt get update because it failed something and it couldnt trust a certificate. when i go back to it tomorrow ill post some kind of error or a screenshot/log.

if there are certificate issues, you maybe running out of time sync.

Yes a log and or screen print would be helpful.

Okay I think I added a capture of the error.

Ok that’s a known issue at Debian server side. Pls try follow

sed -i 's/https:/http:/' /etc/apt/sources.list
apt update
apt upgrade
sed -i 's/http:/https:/' /etc/apt/sources.list
apt update

After it does the error I put that in? Glad it’s a known problem…I thought I broke it. Heh :slight_smile:

Just login to command line and execute the commands. Once completed you are ok to run dietpi-update