Network problem on reboot - Orange pi zero 3

On Opi zero 3 I got a very low performance and high ping on low 5GHz channels, like 36. But I have a low ping and better performance on higher channels like 149.

1 Like

I just tried that ethtool -s eth0 speed 1000, the link freezes out (oops, I’m connected on ethernet).
I’ve had to power cycle, to get the board reconnecting again. And when I’m reconnected,

[   20.517269] dwmac-sun8i 5020000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx

Note that ethtool is run manually rather than patching this in configs.

I think it is partly to do with my up stream ethernet hub/switch, I’ve another computer connected at 100 Mbps and I’m not sure if for some reason it stuck to 100 Mbps after a while.

It’d be good for everyone with the board to test ethernet at 1Gbps (default) and setting ethtool -s eth0 speed 100 and monitor stability, e.g. soft reboot (with reboot command), power cycle etc. But that it would be better if it is after all stable at 1Gbps. If more than a few can reproduce the issue that setting speeds at 100 Mbps is more ‘stable’ than 1Gbps, it may be good to put a note for this board. However, that could literally be hardware related issues that goes beyond simply this board and its ethernet PHY.

/etc/network/interfaces is like such

iface br0 inet static
    #bridge_ports eth0 wlan0
    bridge_ports eth0
    up /usr/sbin/brctl stp br0 on

hostapd would patch wlan0 into the bridge and setting up Wifi
hostapd.conf is like such

I’ve not been able to change the channels at 5ghz (some errors about not being able to determine frequencies), can someone who managed to change the channels at 5ghz share similar configs?
Note that setting the regulatory domain country code causes an error, hence I’ve commented out setting the country code. Did anyone else encounter errors after setting the country code in hostapd.conf? Or rather has anyone else succeeded with setting the country code at 5ghz in hostapd.conf, could you share relevant config?

at 2.4ghz there are only 14 channels and i’ve been able to specify any channel I’d like, I’d guess it is partly that it doesn’t need country codes. But that limits it to 40 mbps. I’ve not tried or rather not successful with trying to run it with 802.11n at 2.4ghz.

Without a country code, I guess there is only a very limited number of global frequencies, and hence also the error that you cannot change it. What error do you see when using something like iw reg set US (AFAIK the AP/interface muat be down for this or restarted)? And/or what does journalctl -u hostapd say when you define the country code in hostapd.conf?

I’ve just tried DietPi on my Orange Pi Zero 3 today.
Ethernet will not working after reboot.
Seems something is not right with DTB or Kernel modules.
I tried kernel 6.6.8 on other distro and it did work.
tio_ttyUSB0_2023-12-31T14:53:07.log (377.3 KB)

Yes a know limitation that reboot is not working. It’s related to ifupdown we use, instead of NetworkManager, that is used in other Destro.

I’m not sure about it.
I made an image by script and it work.
But my base image is Debian 12 debootstrap with mainline kernel.
I’m not test wifi because I removed antenna from the board.
Maybe the official image then install DietPi is not the best idea for now.

@johndo100 and reboot is working on your case?

ethernet is working after reboot
reboot command is failed

after hard reboot, ethernet was working

you need to use sudo command if you are not root user :wink:

sudo reboot

after hard reset only but not after soft reboot command. This is exactly the challenge at the moment.

Yes. I’ve just connected UART and see how that work.
Ethernet interface didn’t up after soft reboot.

yes as far as we could figure out, it’s a challenge with ifupdown