Native PC (UEFI) ssh login problems when HDMI plug is out


After I installed Native PC (UEFI) some strange behaviour happen.
When I have HDMI pluged in PC the DietPi distro seems to boot properly;
in my router web interface I can see the DietPi IP also I can login through SSH using this IP.

When I unplugg the HDMI and I boot the DietPi PC this can’t occur.
The IP didn’t show up in router interface and I can’t login through SSH.
The DietPI is unreacheable.

I have tried on two diferent small fanless native PCs (Shuttle XS35V4 and Mitac Pluto E230);
the DietPi distro was installed on SSD and updated to 6.30.

On both machines the same behaviour.
It is impossible to reach through SSH when the PCs were boot with HDMI unpluged.

Also, I have tried (on Mitac PC) the procedure from here
using a Debian netboot/mini.iso. Everything was ok, until I had rebooted whithout HDMI plug inserted.

The PC seems to boot (the leds blink) but is unreacheble through SSH.

Because I want to manage the machine exclusively through SSH I want to correct this error.

I like so much the DietPi distro and I learned a lot when I used so I don’t want to watch somewhere else to accomplish my needs,
but I don’t have any ideea how to go further. I am stuck here …

You have any ideea?
I miss something?

I know everybody time is limited; any clue could be a start point to me.



many thanks on your report. Well without screen attached and without SSH, we don’t know whats going on. Quite hart to investigate. I will do some guessing as I don’t have a native computer running DietPi.

  1. there could be a graphic card/motherboard that require a monitor connected and not able to run headless.
  2. maybe there is an option inside your motherboard config menu allowing to continue booting, even if there are errors detected. Something like “halt on errors”
  3. you could look around for a HDMI dummy plug to simulate a screen. There are plenty of options on Amazon :smiley:

Oh, thanks a lot for your suggestions!

I will try to find something about video card from manufacturer documentation.

The same here, I will report something about UEFI settings.

I have an HDMI adaptor (HDMI to DVI) and I already tried to trick the PC’s booting with this adapter pluged in but no success.
HDMI dummy plug seems to be more complex than a simple adapter; it is a good point to investigate and test with.

Tomorrow I will use yout suggestions and I will report here.

Thanks for your ideeas and, not last, for your time.


For both minipcs

  1. I tried to find some manufacturer’s information about graphic card or motherboard related to needs about HDMI connection to boot but with no luck.
  2. In the config menus I didn’t find any option related to errors on boot.

so then

  1. I ordered a HDMI dummy plug … but estimated delivery time is between 26 to 30 this month.

I have nothing but just wait.
Surely I will come back to report something here but seems that will be after more than a few days.

Thank you for your suggestions.

yes, pls keep us posted. curious to see if it working

… HDMI dummy plug … this was the solution.

It seems that both my fanless mini computers have blocked the option to boot whithout hdmi monitor attached.

Thank you for your help!

I will try install LAMP, maybe LLMP stack, over DietPi, to squeze the best performance from these mini computers;

I will report here if I will meet some problems, related to DietPi, off course,
even if at the final the problem is not about DietPi but to my ignorance :smiley:

ok thx for feedback. Good to know that its working now. I mark the issue as solved.

LAMP as well as LLMP can be installed using dietpi-software

[ ]      ●─ Webserver Stacks ────────────────●  
[ ] 75   LASP: apache2  | sqlite  | php
[ ] 76   LAMP: apache2  | mariadb | php
[ ] 78   LESP: nginx    | sqlite  | php 
[ ] 79   LEMP: nginx    | mariadb | php 
[ ] 81   LLSP: lighttpd | sqlite  | php 
[ ] 82   LLMP: lighttpd | mariadb | php

Hello! (this is my first post here)

BTW Thanks for DietPi! :heart: I’m using it maybe 5+ years in my all raspberries and now also on miniPC :slight_smile:

I had the same problem! I would like to share my solution:

My HW & environment is similar, but a bit different:

  • Odroid H3 (or ODROID-H3) (x86 Intel N5105) + 1x 16GB RAM + 1x m.2 SSD
    (it has only 1.2 — 1.5 W idle power consumption)


  • official minimal Debian 11 (Debian -- Thank you for downloading Debian!)
  • + applied script to transform it to DietPi using this guide: Make your own distribution -
some more details about the issue
  • Booting without LCD monitor causes restart few seconds after boot
  • here are diff of dmesg logs (left with HDMI, right side without HDMI)
  • I think problem was not in DietPi but in linux kernel because such CPU is quite new and has not proper support in older kernels.
  • I think these lines (at the end of dmesg log) with i915 ... cannot find any crtc or sizes signalizing something wrong with graphics:

Before proper solution I tried to use fake HDMI plug too, it helped, but it was ugly workaround and I didn’t like such solution.

:white_check_mark: Solution

What helped me was upgrade kernel from 5.19.0-0.deb11.2-amd64 to newer: 6.0.0-0.deb11.6-amd64

+ Also I recommend upgrade BIOS.

Hope it will help others too.

1 Like