Mainline Linux/Debian for NanoPi R5S/C

Victory ! At last I was able to compile our module on R5S. It is one year that we are trying to do it !
Much thanks meco.
For us, a LTS kernel is the best option.

Micha will be interested to know that the WAN led works fine (not yet tested the two others)
The LVME SSD is well detected.
Are there any other tests you would like to do ? I cannot test R5C, because I gave mine to a developer, but as soon as I have another, I will test on it the WiFi.

1 Like

That’s awesome can you check for the existence of /dev/rga and /dev/dma_heap too? That would mean VPU Acceleration also works

/dev/dma_heap is present, with inside “reserved” and “system”
/dev/rga is not present

Can you check if Inindevs image had /dev/rga show up?

no, neither /dev/rga nor /dev/dma_heap

This test allows me to correct something I wrote above : I said this image was not working for me, but I made a mistake : I used R5C image on R5S, and this does not work. But the R5S image starts well.

@Averell7 I have a new image that I would love you to test:

  • This should hopefully fix the /dev/rga issue.
    – Please as before look for the existence of /dev/rga and at least one of these two: /dev/dri or /dev/dma_heap

I’ve also included the headers again so maybe you can build your drivers on 6.5 too (I guess 6.1 LTS is more useful for you but check the included changelog maybe theres a reason for you to try 6.5)

I have a display problem : the system starts, because the system led is blinking (heartbeat), but I have nothing on screen and the WAN led is off.

Maybe I’m missing some U-Boot Patches, will look at it later. But there’s gonna be a rga patch for 6.1 LTS soon anyways so not as bad but not “mainline” anymore. Which still for Debian 11 shouldn’t be as big of a deal. Stable mainline has all the patches already from 6.5 onwards just need to build a working image

I have a couple of R5C I can test with if any testing is required.

Hello @meco , I am installing your nanopi-r5c_bookworm-1203.img.xz on a R5C.
I need to rename the internet ports. You do not use udev for that. How do you rename them to wlan0 and lan0 ?

I tested on R5S and R5c : it works very well in both cases.
Nevertheless, there was a problem with R5C : the WiFi was not detected. I saw it in lshw, but not in /sys/class/net.
I just installed the package firmware-realtek, and now it is there.

1 Like

Hi, meco:
Do you have an image for r5c? I don’t have r5s and the the r5s image does not work on my r5c (or should it?). However, I had installed the OMV6 on the r5c the bullseye core image from friendlyelec. It runs but only the read speed (NAS to PC) was good. The write speed (PC to NAS) was very slow. I tried inindev’s Bookworm image with plain Samba. Both read and write speed are good. However, as OMV6 cannot be installed on it, I still would like to have a Bullseye image for r5c so I can try again.
Thank you all for your good work.

you have seen the download link above? Releases · inindev/nanopi-r5 · GitHub

I’ve been running Openmediavault on an R5S for quite some time.
Have you set the Nic MTU to 9000 (PC and SBC)?

For Samba these settings gave me the best results:
oplocks = no
log level = 0
socket options = TCP_NODELAY
read raw = yes
write raw = yes
max xmit = 32768
getwd cache = yes
veto files = /*

I had a similar issue like you that got resolved after I updated my PC Nic driver (mine was Realtek) from the manufacturers Website.

Do you have over 2GBe through iPerf3?

Thanks for your reply!
Are you using the friendlyelec image? I using their image and got very low write speed on r5c/OMV6. The read speed was o.k. Even using plain Samba the write speed is also low. The iperf3 read and write speeds are o.k. (>2Gbs).
Please also help:
In my smb.conf, I don’t have set most of the parameters that you mentioned above, e.g. read/write raw. Do I need to add these in?
Where to set the MTU value in PC and SBC?

Yes. It works very well for me with plain Samba. But it is a Bookworm image so I cannot use it to install OMV6.

You can set the parameters in OMV > Services > Samba/smb > Settings

Thanks. I will give it a try.