just installed dietpi, can't login


I downloaded image

“burned” image to sdcard

placed it in pi2

came up with login screen … tried root / dietpi (all lowercase)

says incorrect password ?


redownloading and reburning image

temporarily put password in username box to confirm not a keyboard issue

tried SSH login says saame


Please try to change the password via dietpi.txt right after flashing. It’s on the fat partition hence should be mounted automatically on Windows.

I just verified, it’s definitely “dietpi” if dietpi.txt is not altered :thinking:.

thnaks I’ll try that

PS i downloaded it from this link … (https://dietpi.com/downloads/images/)

yes that is the correct image. I can confirm as well that it is working for my RPi’s as well

Are you connecting with SSH or typing on a keyboard connected on the RPi?
Are all buttons functioning properly?
Try to type “dietpi” in username field to verify that all keystrokes are sent correctly. Maybe some button is sending different character or maybe it is malfunctioning and doesn’t always send the keystroke.

quite odd

  1. yes I typed in dietpi temporarily into username to make sure all keys are functioning fine when i type it into password box

  2. tried putty and that doesnt accept the password either

  3. tried a customized dietpi.txt file with password changed to 123456 … same problem :frowning:

one thing i noticed is once u boot the pi up, after the initial “cryptic” bootup messages (no errors)… after about 5-10 seconds it goes to the graphical login screen. Shouldnt it take quite a few mins (especially on a pi2) to automatically install updates and config itself before giving the login screen?

Initial updates are done after login. Hmm are you able to take a picture of the boot messages?


automatic update will be started as soon you login.

What do you mean by graphical login screen. Usually if you use the default image, the boot will stay on the linux login promt. There should be no graphical terminal loaded. Can you maybe create a photo/picture from your screen?

found the issue, learn something new everyday :slight_smile:

the sdcard had a previous image of raspbian on there

apparently even after burning a new image over it (successfully with no errors) and using diskpart (clean), the original raspbian image was actually still the true image on the sdcard


1 Like

Yeah, you need to take care that the whole SDcard is formatted and you do not flash to a certain or new partition only. Using rufus + dd flash method should work fine.

I’m having a similar problem. Am a total noob. Only ever pointed, clicked, dragged and dropped before :smiley: :smiley:

Bought a RPi ‘kit’ that came with SD card with ‘NOOBS’ installed on it. Have used balenaEtcher to flash the drive with DietPi. Tried deleting the SD card in Disk Utility (I’m a Mac user) and re-flashing… same issue. Being told my password is incorrect when trying to SSH into the Pi.

Can anyone walk me through how to properly prepare the SD card before reflashing the DietPi image onto said SD card?

Many thanks


if you use the default system, just flashed the SD card without configuration, the default password is dietpi

on further searching a found a thread that had the Terminal command as ssh root@IPaddress. I had been doing ssh pi@IPaddress

I’m now in… after about an hour of faffing!

user pi did not exit on DietPi :wink:

I recommend to have a look to our online docs https://dietpi.com/docs/
There is quite a good section about first start

I did do a lot of reading… that bit just slipped through the net!

All good now. Pi is busy loading up desired software.

I do like a project :slight_smile: