Jellyfin installation has changed

Hi Team. I have moved on to Jellyfin for my project and after going through fits figuring out how to get it to work on Armbian, I head slapped myself and said hey why don’t I just use DietPi, because those guys figured it all out I’m sure.

Guess it has been a while since a visit to Jellyfin, because it throws the same error as if you just install the server deb manually, which lacks the web client now. The instructions on the website are still wrong, but I picked through a lot of forum posts and this methodology works. I guess most people are on windows and not using pis for it so it just isn’t a priority.

This can serve as instructions for those of us who care until it is fixed in the installer. I’m not a best practices kind of guy so if you guys need to comment on better ways feel free. I’m not easily offended.

Since it is a server, these instructions are for SSH’ing into the board on Armbian.

To get the files, use your regular computer with the SSH window, go to:

First go in an get the server package .deb then the web package .deb, which is the browser client. For the arm chips you use either arm64 or armhf for the server. Look up your board to see what it is. On Armbian downloads it will tell you. Of course if you are on x86 you use the amd64.

For the web client, if you are on an arm chip, use the one that says “all.”

If you are a desktop, use the browser of course. If you are on a terminal:

mkdir Downloads
cd Downloads

Right click, Copy, the url of the file. Go into your terminal and


Do that for both. I didn’t apparently need the third option, which is meta. I don’t know maybe that is both.

Then sudo dpkg -i jellyfin-server_10.8.10-1_armhf.deb jellyfin-web_10.8.10-1.deb

Then sudo apt install -fy

and the server should be running. Use sudo systemctl stop jellyfin in case it is running, which doesn’t seem to always be the case after install.

Now there is a little detail that I found in the middle of a long thread. The web client is not mapped correctly in something and you have to do a symlink to fix it.

sudo ln -s /usr/share/jellyfin/web/ /usr/lib/jellyfin/bin/jellyfin-web

sudo jellyfin &
and that should start it

Go to local.ip.address:8096 or if you are on that desktop localhost:8096 and it will walk you through the setup process.

Before you connect a drive, do this:

sudo apt install acl ntfs-3g -y

Then mount the drive to a directory and give Jellyfin permission to see it. Most Armbian desktops auto-mount drives without having to modify the fstab file, but if you are on a server you’ll have to do it manually. DietPi has a widget I know but I have not used it yet.

sudo setfacl -m user:jellyfin:rxw /path/to/drive/

and you should be good to go.

I have no idea if Jellyfin is as flighty as the install process, but Plex is essentially big brother these days and Emby requires you to pay to use many of the clients. I have personally paid for lifetime twice because I think it’s a steal, but I wasn’t crazy about having to register my server with them to use the desktop linux client. Most SBCs can’t handle transcoding the files into a browser compatible format from the native .mkv, and when you use the Emby client it doesn’t not even call ffmpeg at all. Jellyfin seems the same, but already I am seeing that the back end processes of the library filing are completely different than Emby, even though Jellyfin started out as Emby, and so far it seems to be cleaner.

I wish you success. :slight_smile: -ph

Just a question: installation via dietpi-software is not working? I just tested on a demo system and could not find an error.

I don’t know what you are seeing. Tried it twice on two different boards and got the same result. Missing the client software, and when you manually dpkg them, needs the symlink.

And I have to say that I have abandoned Jellyfin completely. It doesn’t automatically play nicely between the server and the clients for mkv files, so you have to tell it where to find ffmpeg. That eliminates 90%+ of ARM pis for a server. I am running Emby on H3 boards no problem. It takes a few tries to munch big libraries, but once it is all in place, when you play through the client it doesn’t call ffmeg at all, and everything is smooth sailing. Jellyfin seemed like a great free anonymous option, but it is not for the light of heart, and probably not for ARM boards in general.

I tried Jellyfin installation on my test system Orange Pi 5 without issues. Application has been successfully installed using:

dietpi-software install 178

This is going to install following components automatically.

root@DietPiOPi5:~# dpkg -l | grep jelly*
ii  jellyfin                           10.8.10-1                      all          Provides the Jellyfin Free Software Media System
ii  jellyfin-ffmpeg5                   5.1.3-1-bullseye               arm64        Tools for transcoding, streaming and playing of multimedia files
ii  jellyfin-server                    10.8.10-1                      arm64        Jellyfin is the Free Software Media System.
ii  jellyfin-web                       10.8.10-1                      all          Jellyfin is the Free Software Media System.
1 Like

I don’t know that I could replicate my path. It failed on a RockPro64 and and something else, I don’t remember what. The RockPro64 has given me fits on other things since, but I don’t think they would be related.

I had already tried to regular install it with the single .deb package on Armbian as I said, and when I used the installer on DietPi it gave me the same errors. I’ll try it again on something else. I’m testing the Opi3 now, but you guys don’t have much Opi support. I’m sure I have something besides the RockPro64 here I can try it on. Most of my pi stuff was banished by my wife to storage. I think I have a C2 or something around somewhere.

it would be helpful if you could share the errors you are receiving using our dietpi-spftware script

I just installed it on an N2 and the 8096 port does not come up by default, so I manually checked it. Same error that web client not installed.

Then when I follow the instructions above:

why are you trying to starte Jellyfin manually?? It will be started automatically by a systemd service. And there an environment file /etc/default/jellyfin is used defining the web client path, installed by the jellyfin-web package.

As I said, 8096 was dark. That means that it was throwing an error on startup and dying I assume. Could be you can just do the symlink because the client is already there. Just thought of that actually. Did you try 8096 on the one you installed?

On DietPi, we use port 8097, as stated on our online docs Media Systems Software Options - Docs

Web interface is showing up without issues.

1 Like

That’s hilarious. So strike that reverse it lol. I hope people who find this thread scroll to the end. So here endeth the lesson. RTFM

yes, for some apps we need to move away from standard/default ports to avoid conflicts between apps and to allow parallel execution. On DietPi, port 8096 is already used by Emby Media Systems Software Options - Docs

I can confirm that my instructions above are completely not needed. It comes up on 8097 just fine. :slight_smile:

Thanks for the followup @Joulinar I am going to re-evaluate Jellyfin with your tweaking.

1 Like