Jackett reset after reboot (lost API, indexers)

Hey guys.
I have a problem with Jackett, it doesn’t keep settings like API and indexers after system reboot. Problem appeared today, maybe it exist since yesterday, but I saw it today when both Sonarr and Radarr showed error with indexers. After I reboot RPi4 and go into Jackett everything is reseted (new API, 0 indexers). I think that yesterday I probably made some apt upgrade (13 packages) that appeared in launcher, but really don’t remember what was updated and if this is a problem. Tbh I don’t know what could cause this, because despite occasional apt upgrades I didn’t install any new software.
Even reinstalling Jackett (dietpi-software reinstall 147) didn’t help.
If you need any logs please instruct me what you need and how.

I have exactly the same problem - all my indexers are gone - they took ages to configure as well. Hoping they are still there and can be recovered.

Exact same thing is happening to me as well. I don’t know when it stopped working, but has been in the last week or so. I just noticed today that Radarr and Sonarr were only getting NZB results, no torrents.

Same here… i am facing this issue since apt upgrade yesterday which I think upgraded 13 packages…

It happened to me as well. I tried to restore the indexers from backup, however upon starting the jackett service, everything is wiped out.
I tried to add a couple from scratch, then restarted the service and they were again vanished.
I am getting these error messages, most likely connected to the fact that /opt/jackett/Jacket/ folder is deleted.

dietpi@RockPi:[/opt/jackett/Jackett]$ sudo dietpi-services status jackett
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
job-working-directory: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

Same thing happening here after a fresh install earlier today, thought I was loosing my marbles.

The same thing happened to me. It seems like Jacket is wiped and a new API key is generated. It worked for two days before it rewiped everything. :roll_eyes: Even though Jackett service seems like is running ok let us see tomorrow if it is yet again deleted.

root@DietPi:~# dietpi-services status jackett

 Mode: status jackett

[  OK  ] DietPi-Services | jackett		active (running) since Thu 2021-04-01 15:40:59 CEST; 6h ago

I’m having the exact same issue. All started after I ran apt upgrade yesterday.

DItto. Following along…


possible references to to issue :


Not had time to try anything suggested yet or even if applicable to dietpi installation. I did notice some people were able to get their config back which looks promising.

I have the same problem. Every reboot causes this as well.

So the workaround on git is to change the config location , however I’m not sure where exactly this is referenced in the service file, mine looks like :

Description=Jackett (DietPi)
After=network-online.target dietpi-boot.service

ExecStart=/bin/dash -c '/opt/jackett/jackett --NoRestart; while pgrep -u jackett JackettUpdater > /dev/null; do sleep 1; done'

# Hardening


I created a jackett_config folder in /opt/jackett and changed the line:




and then copied the config stuff over from /opt/jacket/Jackett and restarted but Jackett didnt run at all.
I’m guessing that I’m redirecting in the wrong config line, can anyone care to advise ?

Ok should have looked at the logs, just needed to change the permissions on the newly created folder. All good, surviving reboots now.

did your old config and keys survive?

Maybe it would make more sense to move the config location to /mnt/dietpi_userdata/ to be alligned with the other *arr configs?

I got it working:

sudo mkdir -p /mnt/dietpi_userdata/Jackett ; sudo chown jackett:jackett /mnt/dietpi_userdata/Jackett
sudo nano /etc/systemd/system/jackett.service

Change Environment=XDG_CONFIG_HOME=/mnt/dietpi_userdata and ReadWritePaths=/opt/jackett /mnt /var/log/jackett /tmp
Then run

sudo systemctl daemon-reload

Now it’s a good time to restore from your dietpi-backup

sudo cp -a /mnt/backup/dietpi-backup/data/opt/jackett/Jackett/* /mnt/dietpi_userdata/Jackett/

Finally cross fingers and start it sudo dietpi-services start jackett
The api key will still be the same.

First time post and registering because of the same issue, but found this through Google, so glad I’m not the only one that is having the same issues :frowning:

I tried this and all I got within the dietpi-launcher > services was that Jackett was activating and didn’t go much further. Uninstall & reinstall got back to it working, but still with the indexers & API key changing after a service restart.

I have noticed that the build number has changed on Jackett overnight though from v0.17.820 (I think) to v0.17.838 now, so guess this is being looked on from the various github comments.

I guess there will be a fix soon enough, but keep up the work guys and gals, it is hugely appreciated :smiley:

What is the error? sudo journalctl -u jackett.service

For reference: https://github.com/MichaIng/DietPi/issues/4237

ok learned lesson about the dietpi backup! I dont have one… since the jackett files only got deleted 2 days ago and ive done nothing with my pi since… how can i go about recovering the files?

I tried following a testdisk tutorial but it didnt really help - unsure of the location where the original files that are gone and meant to have stored.

Any help appreciated… really dont wanna set it all up again (all my indexers).

Also is it easy enough to cron the dietpi backup tool?