404 | Failed connection test

If you are experiencing this issue, please see the following link for info and a resolution:
Hi. I just wrote a DietPi image for a OPi PC and though it boots ok, the installation wizard says there’s no internet connection after trying which is 404. As that is the web it uses to determine if there’s internet connection, I can’t continue with the installation. After that, it prompts to execute a manual test which is successful and checks that in fact there is internet connection, but when I choose install, the same test to is made and the installation can’t continue. Can you guys tell me how can I fix this? Thanks.

P.S After quitting the installation wizard, I ran apt-get update and apt-get upgrade with no problems. I’ve upgraded to the last version of DietPi but the problem seems to be the default test URL.

EDIT: Ok, I searched deeply in the DietPi install wizard scripts and managed a way to get over this error without breaking APT. Do the following with root permissions:

nano /etc/apt/sources.list


deb jessie/updates main contrib non-free

on top of the list. The textfile should be as follows:

deb jessie/updates main contrib non-free
deb jessie main contrib non-free
deb jessie-updates main contrib non-free
deb jessie-backports main contrib non-free

Thanks so much for posting this fix, I was just about to go delving around to see if I could get around it with the sources list but you saved me the trouble.

Great stuff - glad I checked the forum now!

Hi all,

on top of the list. The textfile should be as follows:

Interesting that works, thanks for sharing :slight_smile:

We are aware of this issue and looking to resolve it for v145. It appears Debian has changed their webserver configuration over night and now requires a / at the end of url entries:

A quick solution is to exit DietPi-Software and select another APT mirror:
dietpi-config > Networking Options: NAS/MISC > Apt Mirror

Modifying sources.list solved the issue. Thanks JnGutierrez.

BTW, while I was trying to install, I did change the mirror site. Prior to the test, It was changed to a known good site. The status of my connection was then all good. The issue with running software remained though.

Thanks for the help.