Help needed - DietPi & WaveShare ETH/USB hub (B)

I purchased the Waveshare ETH/USB hub hat which adds an ethernet port and 3 USB-A ports to a Raspberry Pi Zero however I am finding difficulties to get it working with the DietPi distribution.

These are the steps I followed:
I have added it to my Raspberry Pi ZW and loaded up the latest version of the DietPi 8.14.2 (ARM v6) for the Raspberry Pi 1/Zero.
After doing the changes in the dietpi.txt and dietpi-wifi.txt files (to automatically add the WiFi details) and editing the config.txt file (to add “dtoverlay=dwc2,dr_mode=host” in order to enable the hub, as per the instructions from the Wiki) y get the microSd card into the Pi, let it boot for the first time and give it a few minutes to do its first boot.
I connect via SSH, do the initial configuration, change passwords, install software etc, and done.
I then execute the dietpi-config to go onto option 7 “Network Options : Adapters” and can see that the Ethernet Adapter options appear as “Not Found [Off] Disconnected”. Selecting it indicates “No ethernet adapter was detected on your device”.

I am therefore unable to use the ETH port from the hub to connect my R.Pi Zero to the network via cable.

If anyone could help me get it working I would appreciate it a lot. Many thanks in advance.

maybe something @MichaIng could help with.

ip l does not list it either, right?

Are the USB ports functional?

Did you test this on Raspberry Pi OS?

Many thanks @MichaIng

ip l


neth is a Wireguard connection to a VPN

If I am honest, I have not tried the USB ports yet, and I have not tested with the Raspberry Pi OS yet either. I will try both and will report once done.

Also check for kernel errors, probably it is just a powering issue:

dmesg -l 0,1,2,3

When I plug a USB stick nothing happens.
fdisk -l does now show any additional devices (other than the ram and sd card ones associated with the dietpi install) in /dev/

dmesg -l 0,1,2,3

This is the output from the command.

dmesg.txt (30.0 KB)

It seems that your suspicion about the lack of power may be it, although the USB charger I am using to power the R.Pi Zero is rated 5v 1A and should be enough for it.
I will try a different charger rated 2A in a bit,

Jep, that looks pretty much like a USB powering issue, affecting the whole HAT that way, or bad physical connection. What does vcgencmd get_throttled show?

Changing to a 2 amps microusb charger did not resolve the issue.
Ethernet Adapter options stil appear as “Not Found [Off] Disconnected” / “No ethernet adapter was detected on your device” in 7 “Network Options : Adapters” from dietpi-config.

vcgencmd get_throttled 


I will be trying a Raspberry OS installation next.

That makes sense. Errors are gone now at least. USB ports still do not work?

Nope, USB still do not work. Plugging a USB flash drive does not result in any mounted device, same as before. :-m

Ah, do kernel errors in dmesg -l 0,1,2,3 reappear when you plug the USB device?

No, they have not reappeared so far after plugging the same USB flash drive.

And does the kernel log other messages related to the attached USB device + does lsusb show it?

dmesg | tail -20
xuxo@Getter:~$ sudo dmesg | tail -20
[   12.060144] dwc2 20980000.usb: irq 33, io mem 0x20980000
[   12.060607] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.15
[   12.060638] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[   12.060658] usb usb1: Product: DWC OTG Controller
[   12.060675] usb usb1: Manufacturer: Linux 5.15.84+ dwc2_hsotg
[   12.060691] usb usb1: SerialNumber: 20980000.usb
[   12.080533] hub 1-0:1.0: USB hub found
[   12.080674] hub 1-0:1.0: 1 port detected
[   14.336496] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[   14.604197] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[   15.282905] brcmfmac: F1 signature read @0x18000000=0x1541a9a6
[   15.309780] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
[   15.338620] usbcore: registered new interface driver brcmfmac
[   15.685427] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
[   15.701605] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43430/1 wl0: Jul 19 2021 03:24:18 version 7.45.98 (TOB) (56df937 CY) FWID 01-8e14b897
[   17.401110] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save disabled
[   18.810909] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   19.881127] wireguard: WireGuard 1.0.0 loaded. See for information.
[   19.881162] wireguard: Copyright (C) 2015-2019 Jason A. Donenfeld <>. All Rights Reserved.
[   31.850254] cam-dummy-reg: disabling

xuxo@Getter:~$ sudo lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

As if the HAT would not exist at all :thinking:.

let’s see how it behave on RPi OS

Well, it behaves the same in a freshly Raspberry Pi OS Lite installed. Same behaviour (Flash drives do not appear anywhere) so I must be doing something wrong.

The hat itself can be connected to one of my laptop USBs and is recognised (pluggin a USB drive in the hat will automount the contents) so the hat does work.

I have had enough for today, so will try again in a few days. If anyone has had experience with these hats and can suggest anything, please do. Many thanks.

I will attach the full dmesg output from the Rasperry Pi OS for reference, but I cannot see any errors.

dmesg_rpiOS.txt (22.6 KB)

xuxo@raspberrypi:/etc $ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
xuxo@raspberrypi:/etc $ dmesg -l 0,1,2,3
xuxo@raspberrypi:/etc $ vcgencmd get_throttled 
xuxo@raspberrypi:/etc $

does it show on lsusb

Make sure those pogopins are touching the little pads underneath good too…if they all aren’t touching properly USB won’t work, plus the RPi0 needs to be snuggly attached to the board

I have several of those and the newer PoE hat as well

If they are touching…and it still doesn’t work…rma it and get a new one

What version of RPi0 do you have…some of these hats only work with the later revisions

Make sure you don’t have it mounted backwards (ask me how I know :sweat_smile:)

Maybe you could ask for vendor support if your HAT is not working on plain RPI OS as well.

Yeah, sounds like you might have gotten a bum unit…if it’s not working on the hardware something either the pi, or the hat is not working, especially if you replaced the os and it does the same thing