Got error 'Primary script unknown

I’m trying to install “” on my new raspi 5. But I wont let me install it.
Error message in the system log files says : Feb 05 09:46:24 homer apache2[7300]: [proxy_fcgi:error] [pid 7300:tid 547521368320] [client XX:xx:xx.XXX:49619] AH01071: Got error ‘Primary script unknown’

I found something on the internet related to this messages , but I’m not an expert in this field. I’m using Gallery for years already on Raspi’s either PI os or Debian variants without problems.
Presently the Raspi 5 run’s with Dietpi and basically every works. For comparison I tried to install it also on an Raspi 4 with Dietpi. But also no luck, same error message.
So before I break something else I better ask :grinning:
Any further Info required from my side pls let me know.

I changed this thread to troubleshooting category.

Can you please provide the output of following commands, to gather some info about your system:

cat /boot/dietpi/.version
uname -a
dpkg --print-architecture
cat /boot/dietpi/.installed

Pls find attached

Hm you fulfilled the necessary requirements which are listed in the photo gallery docs.
Where in the installing process does it fail?
You uploaded the x3_installer.php into /var/www ?

the uploader script is located in /var/www/x3 and I can start it accordingly ( ) result as per screen shot

When clicking on Start X3 install this happens

I got it working on my testsystem, but with nginx instead of apache web server.

I will also try with apache now.
Ok it fails for me with the same message as yours with apache web server.

Best would be to ask the dev of this app why this is happening, they say they support apache.
Maybe they do not support PHP8.

Hi ,
tks for your help. As per X3 website they also support php 8.2. I will contact them and report

the developer of X3 replied to me

henning wrote: Hi,
I’m trying to install X3 latest version on my new Raspi 5 with “Dietpi” However the web installer does not work. I can start the script and on the 2nd page
it stops and complains about being not able to download the necessary files.

Well, it basically means PHP Curl failed on your server, without giving any specific reason. You would need to diagnose the curl function directly, it just doesn’t work on your server.

How can I test that curl thingi ?

The thing is, it works on nginx but not with apache. So curl works.
You can test it with curl

Why you don’t install a gallery from the DietPi software catalogue?

Hi, the thing is that I use X3 already for years and have been moving it from a dedicated server to Raspi 3 and 4 and now it’s a raspi 5 :slight_smile: Sofar no problems and / or loses of data encountered. On the other hand I used always Apache have never used NGINX sofar.
My Raspi 5 is not yet complete on the hardware site. NVMe SSD is missing . The extension board from Pimoroni arrived today. The ssd is on the way. Wait and see :slightly_smiling_face:

DId you try to curl manually?

yes , after a little bit playing around with it the file was downloaded and I could install it. And so far everything works. There was a little problem with the build in “Diagnostics” . But after disabling it all was ok.
Tks again

1 Like

I have to comeback to my X3 issue. It’s installed and the admin part is working. So I can see the frontpage with all the menue items etc etc. However when ever I click on a gallery it tells me :
Not Found
The requested URL was not found on this server.

I have a separate Raspi 4 with Pi OS and I can install it with apche2 and it works. Obviously it works with nginx.
As an amateur in programming I would say the the webserver is looking at the wrong place ?
Or is dietpi soo much different from PI OS or bookworm ?

Tks for any input

do you see the target URL?


Step 1 calling up the relevant page

Step 2

Step 3 finish
Step 3

After it’s done. No pictures are shown . Also no preview

I understood this. My question was, if you see the related URL if you move the mouse over the button.

Yes , I see at the bottom the relatet link

And? What is it?

The mouse is over landscapes and it shows it also at the bottom

and the folder exist below /var/www?