First run FAILED


I downloaded and install on micro sd card, put in my RPi4b 8GB and start
After start ask me login
after I got: [FAILED] DietPi-Login I Failed to load DietPi-Globals. Skipping DietPi login scripts…

What now? :thinking:

Please try to run the following commands and paste their output here:

. /boot/dietpi/func/dietpi-globals
echo $?

Which image was it? ARMv6, ARMv7 or ARMv8?

Probably as well to share following 2 files located in /var/tmp/dietpi/logs


Yesterday I tried 4-5 times in a row to start this OS.
All the time got that failed message.
I put the sd card to my desk, and wait your answer.
Today I put back the card to the RPi, and started.
It started totaly different /I did not do anything with the card/
Yesterday ask me to login, but did not show what is default username and password.
I checked on internet with my phone.
Today it shows what is the default name and password, and after I type it not dropped that feiled message…
But after coming different and different error messages.
Most of them I can cancel it, or exit,
But firefox installation droped an error message, and did not let me to do anything.

I am installed ARM8 64bit, because I have RPi4b 8GB version.

This OS is extremly hard to install.

This OS is extremly hard to install.

Nope. the other way around. It’s extrem easy.

There seems to be an issue with your install/SD card/image. Could you try to download a new image from our web site and flash it again. To reduce possible errors, try to use a default setup with limited amount of config changes done (during inital boot).

As well it would be highly appreciate if you could share your errors more in details. Best is always to share the entire error by simply copy them from SSH terminal.


So, I downloaded AMR8 again, and make an sd card again.
First start I got FAIL agai

I did what you recomend

and I do not have var folder, so those 2 files does not exist
here is the full files on the card

After 2nd start I can go through, I choose xfce, but nothing, I got this, and nothing more:

I think this OS is not to me

In Windows you can see BootFS only. The RootFS is not visible as it’s an ext4 Linux file system (not supported by Windows). There you would need another Linux box or VM to be able to access the RootFS. As an alternative you can copy files from the ext4 partition into the BootFS.

You installed xfce, did the installation completed? Usually at the end you should be ask if you like to set automatic start into Desktop mode.

That picture is not Windows, thet is Mac OS, so there is no other files.

Installed all, I chaneg Chrome, and xfce, because last time fifefox cannot install itself.
There was no question about Desktop mode.

I guess you changed desktop and browser preference only? This means no actual installation was triggered as this would be a preference. For install, go to dietpi-software, search for xfce and hit install.

Doesn’t matter if Windows or Mac OS. Both can’t read Linux file system ext4. Means you will not see the 2nd partition. This require additional software. But not sure what it would be on Mac OS

On first attempt, the /boot partition was not mounted at boot for some reason. If this happens again, you can diagnose with those commands:

journalctl -u boot.mount
fdisk -l /dev/mmcblk0
mount /boot

I start from the beginning, delete sd card, install, and start from the beginning.
Now I select to install xfce and choose desktop to xfce.
Now failed from other place…

So this OS is not only hard to install, but impossible.

Thank you so much for your help to all of you.

Your SD card seems broken. This means that the intended install state was not written, or probably the boot partition got suddenly unmounted. Additionally to the commands provided above, please check the following to check for kernel errors:

dmesg -l emerg,alert,crit,err

No problem with SD card. Other system runing well on it.
I am pretty sure I do something wrong.
I am a beginner in the Linux world, and exremly hard to install this system to me.
Most of the question I just push something, because I do not understand.
If I click “next next next” without change anything /xfce, chrome/ the system stuck with firefox, there is something wrong with firefox installer.
If I change only firefox to chrome, the system installing, but not on desktop mode, and I do not know how to get in.
So I think it is my fault, but do not know what to do.
If I cahnge something, all time coming differnt and different problem.

Please run the command I provided and paste the output here. At best run things via SSH connection so that you can select for copy&paste the console text, instead of taking photos of the screen.

The screen photo you showed can only happen in two cases:

  1. The content of the boot partition is not as expected, which is (in combination with the previous “Failed to load DietPi-Globals” error you faced) why I thought about an SD card issue, filesystem corruption or similar. This could be verified by the given command.
  2. DietPi-Update or DietPi-Software encountered an error. In this case you should have seen an error prompt before the one you showed and we’d need the error messages given there.

Clicking “next next next” should be fine, however you’ll have a minimal install without desktop or browser then. Note that the “Preference” selections, as stated in those menus, only define a preference (for a desktop or browser or webserver) IF (and only if!) another explicitly selected software requires such. E.g. if you select Nextcloud, the webserver preference will be respected to install the webserver of your choice, since Nextcloud requires a webserver. Same for VNC servers and desktop applications and the desktop preference. The browser preference defines the browser that will be installed IF you select a desktop explicitly (not via preference menu only). But this should be all described well in the menus. You can hit “next next next”, but at least read the text that is given if you expect any specific outcome :wink:.

This means, I guess you didn’t chose a desktop or browser via “Browse Software” or “Seach Software” menus, but only via preference menus, which results in nothing being installed, as stated above. But it doesn’t explain the errors you faced.

I found it what was the problem.
I used the RPi Imager to make the SD card.

Now last time, I make with balenaEtcher and was no fail message anymore, it worked for the first time.

So cannot use RPi Imager, because it couse all the problem what I got.

balenaEtcher is the tool we recommend to use to flash the images.

Hmm, RPi imager works fine for me, just tested it a couple of times. It has some options to pre-configure parts of the boot partition, enable SSH etc, but those are only valid for the official Raspberry Pi OS image. Did you probably change something with these and it was applied even when using a custom local image file? If so, we should add a fix to have these additional options only applied when the regular RPi OS image is downloaded, or based on a specific marker when using a local image.


No I did not changed anything /I do not know how can I/
I started the RPi Imager on Windows 10 pro, Choose OS, scroll down, Use Custom.
I choose the DietPi_RPi-ARMv8-Bullseye.img , after Choose Storage, only one there what I can choose.
RPi Imager wersion 1.6.2
RPi4B 8GB /newest cpu inside, end with …6C0T/ I bought a month ago only.

Strange, I’ll retest with RPi-Imager when I find time. Usually I use Rufus to write images from Windows, much smaller and faster and still more advanced than Etcher :wink:.

Jup switch to Rufus as well, exactly for same reason.