Done it again - need to reset Transmission password

I feel such a silly fool. I’m normally so good with passwords - I use a password manager and everything…

But I’ve not recorded my Transmission password anywhere. How do I reset it?

why not following your own post again

I did, but the situation in that thread involved all sorts of uninstall, install shenanigans. The post in that thread, the one that suggested the commands below, didn’t work. After executing it in Terminal when I try to access Transmission I’m asked for user name and password - no opportunity to reset my password.

systemctl stop transmission-daemon.service
G_CONFIG_INJECT ‘“rpc-password”’ ’ “rpc-password”: “new-password”,’ /etc/transmission-daemon/settings.json
systemctl start transmission-daemon.service


I have successfully uninstalled then reinstalled Transmisson - was hoping that on reinstalling Transmission would prompt me for a password. But it didn’t

Really not sure what to do now.


try to clear browser cache or use a different browser

Have tried both, but still no joy :cry:

Oh no, have I come to the end of the road with Transmission?

I tested Transmission on 5 different systems and it was working well all the time. I was ask for a password and could login

  • Bullseye VM 64bit
  • Buster VM 64bit
  • Bookworm VM 64bit
  • Bullseye RPi3B+ 32bit
  • Bullseye RPI4B 64bit

Do you use any special character on your application password?

What are the settings on configuration file

cat /etc/transmission-daemon/settings.json | grep "rpc-"

Thanks for looking into this for me. much appreciated.

Where do I find the Config file for Transmission?

Only special characters are ^> and < - they’ve not caused problems before.

Doh… I can see what I did… I copied your initial code exactly, so the new password was ‘new-password’!

Am now in and all working OK

Thanks again!

Sorry to say but: wtf :sunglasses: