DietPi x86 Roon server not authorised to access smb mounts

Hi I have setup my first x86 install of diepi, got all my network mounts sorted, installed Plex and it can access all these no problems. Installed Roon via your installer and it cant access any mounts to network storage I have made that everything else works no issues. I can add a network mount using its inferface all ok but I cant see contents of any directories. Any ideas, it feels like the install has different permissions, it will see local disk fine and usb mount just not any network folder.

You can’t access it via roon? Do you have access to it via user root on CLI?
And where did you mount it?

They were all set up with dietpis disk utility ap and no it would not acces them at all via Roons interface. I said it was accessible by everything else and via cmdline. After I added roonserver to the dietpi group it worked, so this is a permissions thing setting up Roonserver as it runs as user roonserver not dietpi. Plex however runs as plex and works just fine with same mounts.

Yes exactly, almost every app gets it’s own user on DietPi.
It’s recommended to mount it under /mnt/dietpi_userdata/Music, then you should have access without fiddling with permissions and user/group settings.

If you mount it somewhere else you need to adjust permissions for the share by yourself.

1 Like

That should be documented then. it was actually my database backup I needed not music. So would need to have made a new mount anyway.

From the docs:

When configuring your Roon Server, we highly recommend using the DietPi user data directory. This will allow you to transfer music over the network easily (see Transfer music tab), and storing the music on your Roon Server system:

/mnt/dietpi_userdata/Music
2 Likes