DietPi vs Raspbian Lite!

Resource usage and performance comparisons with similar distros on multiple boards can be viewed at: https://dietpi.com/stats.html

We are open for feedback to include further comparisons into that page. You can review the source code here, feel free to open an issue or pull request.

1 Like

YEAH!

TELL’ EM Fourdee :smiley:

DietPi rulezzzz

Hehe, dam right :slight_smile:

Thats because I can say “I installed DietPi. And I dont want to listen about Raspbian.” :slight_smile:

I just try Raspbian Jessie Lite. I am having problem during the initial boot.
I stuck in the screen on “A start job is running for…,” and it never boots up. I have to turn off my raspberry pi in order to reboot.
2nd boot works fine after the initial boot, however, the “sudo reboot” command seems not working after I edit the /etc/fstab. I put the log files in the ram drive.

so far this is my experience on Raspbian jessie lite

My experience with Raspbian was a WTF have I just bought moment (and that’s not all that long ago!) Awful doesn’t begin to describe it.

Gimme DietPi all day, every day. I’m slowly migrating all my ARM SBC machines to it.

Why isn’t it more popular? Seems to me this is how GNU/Linux is supposed to work!

All my Arm systems (1xC2, 3xXU4CloudS, 1xBananaPro) are migrated to DietPi and I’m very happy with it.

Good work :slight_smile:

Good to here, thanks for letting us know. :slight_smile:

Ps, nice boards :smiley:

OMFG, how come it took me four months to discover your BRILLIANT work!

I am gabriel, and I have seen the light.

A million very lowly gracious thanks to all contributors involved in making this (distro?) happen. I am back at geeking around software after a 15 year hiatus and I am taking on small electronics and sbcs projects for my general personal use.

IF I ever can be of any help i’ll try to be.

Thanks again,

_
gabriel

(off to the tattoo shop: where will i put this now?

1 Like

Hi Gabriel,

Thanks for the feedback, great to hear :slight_smile:

I wouldn’t recommend a tattoo, just in case we split up lol :wink: Would look awesome though :slight_smile:

Count me as another user who had nothing but trouble installing Raspbian. I searched for alternate RPi distros and found DietPi. I was able to get it up and running and connected to my wifi network within minutes! Got my backup and user data set up on a USB thumb drive, and Apache/PHP running with some very nice APC management scripts that came with the DietPi PHP package. You guys saved me a tremendous amount of frustration! Thanks!

I think DietPi wins easy. So many awesome scripts, everything automated to make nice experience while using it. Stable and lightweight DietPi OS is on higher level than Raspbian. :sunglasses:

To add to the fanmail I have had DietPi running successfully on Pi 1, 2 and 3, Odroid XU4 and BananPi M1.

On the Odroid XU4 with Cloudshell display it is unbeatable.

Could someone update the documentation or clarify my misunderstanding. The spreadsheet linked to above compares DietPi to Raspbian Lite. I know it’s not the current release, but why has the minimum SD card size has jumped from 1G to 4G?

Could someone also tell me why I can only download a Stretch version for RPi when Jessie is available for other platforms? I have searched for this info (not extensively I admit) but not found it.

Yeah, agree, we need an update here. I will be able to do one, once v6.0 is released, which should be this sunday, as everything is going as expected.
One reason for the minimal SD card requirement raise was, that the default swapfile size was raised, so that RAM+swapfile together has 2 GB. This was due to some concerns, that 1 GB might not be enough to ensure no emergency process kills. This could be rethought, as it strongly depends on the software you want to run on it. But e.g. on my RPi2 (1 GB RAM) with full featured Nextcloud, where I normally never break 300 MB RAM use, on daily cron at night, where heavy backup and other maintenance tasks are configured, I already had some random process kills due to low RAM, resulting in total SD card corruption (especially MySQL) one time. I had swap disabled that time. Now I have it enabled (giving me 2 GB full RAM). Of course on 512 MB RAM devices, this means 1,5 GB SD card already just for swapfile. 2 GB then is already quite low for other system/software :wink:.

I’m going to chirp in here too, I am amazed that i have ONLY JUST found out about DietPi when i was looking for a method of creating a simple no fuss NFS on my pi. All i can say is i am a bit of a n00b when it comes to linux but this build made it so easy and made perfect sense! thank you so much and can’t wait to continue to use DietPi on all my builds.

Hi,

Many thanks for the feedback and using DietPi, its great to hear :slight_smile:

I made a current comparison, sadly I forgot to measure/write down the boot times, and now my Pi is back in production. Better then nothing:

Test system

  • Raspberry Pi 2 Model B
  • CSL 5V 2.1A power adaptor
  • Kingston SDCA3/64GB U3
  • Raspbian Stretch based system
  • direct terminal access via monitor and keyboard

After comparing both available systems, I used the PREP_SYSTEM_FOR_DIETPI.sh script to upgrade Raspbian Lite base image to DietPi, using the possibility to skip WLAN related packages: DietPi-Prep

Version/Date
Raspbian Lite: 2017-11-29
DietPi: 6.0 (without network access => no 1st run update to 6.1)
DietPi-Prep: 6.1 (with network access => all packages + DietPi up to date)

Download size [MB]
Raspbain Lite: 347
DietPi: 80,6

Image file size [MB]
Raspbian Lite: 1730
DietPi: 666

Root partition size [MB]
Raspbian Lite: 1046
DietPi: 445
DietPi-Prep: 387

  • Raspbian Lite now offers automated file system expansion as well :exclamation:
  • What is the reason, that raw image sizes are larger than the files, finally laid out on disk :question:

Installed packages
Raspbian Lite: 439
DietPi: 247
DietPi-Prep: 232

Memory usage [MB]
Raspbian Lite: 32.3
DietPi: 27.1
DietPi-Prep: not comparable, access via SSH, active network and dietpi.txt 1st run preparation (headless, disabled HDMI), but was down to 24.3M after 1st run setup.

Active tasks
Raspbian Lite: 18
DietPi: 10
DietPi-Prep: 10+1 for active SSH session

Real performance measurements would be nice, I know, but I didn’t want to stress my actual production system too much and also wanted to bring it up as fast as possible. Horrible, to run 2 days without calendar sync :rofl:.

I’m glad everyone is having fun with DietPi. My experience is a bit different. See post https://dietpi.com/forum/t/rpi-zero-w-keeps-rebooting/2449/1

I’ve installed it on a Pi3 B+ and installed the WifiHotspot and it works great. But my issue is with the PiZero W. Any package I install so far cause the Pi Zero W to just keep rebooting. Has anyone installed it on a Pi Zero W?

Hi there,
This is my feedback comparing dietpi and Pi OS lite. This is also my first contribution to this forum.

I wanted to have alternative system for my pihole on pi zero w. I have exactly zero experience with dietpi.
Installation: Documentation to install is not great. I was looking for instruction how to DD or copy provided image to sd card, never found one, so I simply tried. I was looking for making a wpa_supplicant, because, remember, it is pi zero w, no keyboard, no monitor, no nothing. I figured out that wifi is set in some alternative place. ssh is enabled by default, nice.

First boot. This was painful, interactive guide was insisting on testing DNS resolv, but probably under ipv6. It keeps failing.
When I force it, using ping to 1.1.1.1 or something along those lines, it works, sort of.

System then self updates, without asking me about it. At least it did not failed. Pi OS lite fails on apt-get upgrade when deploying new firmware and kernel…bricking device like pi zero w.

When I try to install anything, say pihole or nmap, it start nagging with testing my DNS, using hardcoded quad servers. My DNS is just fine, why it keeps nagging? I run alternative command ‘true’ but why it does not offer ignore option?

At the end of day, I gave up (for now), I do not know if I have or have not ipv6 address and/or connectivity on this device, or if there is some problem. Why is that important enough to keep nagging about it every 30 seconds?

What it can and can not do? How do I install software withhout that dns nagging propmpt? What was my ip, both v6 and v4? is zeroconf running? mDNS?

WHAT I LIKE: less writing, by default. SD should work longer.