Dietpi (stretch) Virtualbox image will not import?

Perhaps I’ve missed a post as I don’t frequent this board much, but today I finally got around to attempting to import the new OVA into my Virtualbox install and I get the following:

Seeking within the archive failed (VERR_TAR_UNEXPECTED_EOS).

Result Code:
IAppliance {8398f026-4add-4474-5bc3-2f9f2140b23e}

Actually, a friend contacted me today asking about this issue as he was unable to get Dietpi running in his Virtualbox, so I thought I’d give it a whirl and have the same experience.

Other OVA’s import fine on my machine, including a new VB install in a new OS I’ve never used before, so I don’t think it’s me… but it could be! :smiley:




Thanks for the report:


An “end of stream” or “end of file” error means that the OVA is incomplete or truncated. The cause will depend on how you transported the OVA: this could be a failed download, or a file which was corrupted due to being transported on a disk that can’t handle large files (e.g. a FAT formatted drive).

I’ll check the download/server, see if its an issue our end.


Appears to be running fine

Please can you try re-downloading, extracting and importing the .ova from above link?
If problems persist, which host OS is the VB running on?

Works fine for me here.

Same error with the new download. This is WEIRD.

For the record, I’m using Ubuntu Mate 16.04 and I have the earlier version of Dietpi for VB installed as well as Windows 7 and Windows 10 for my once a year tax season use, with free software that won’t run using wine and is not available for Linux.

The really weird part is that it’s not only me, but a chap who lives an hour drive away from here?



The plot has thickened!

I have been toying around with Manjaro and got Virtuabox going in it. I downloaded the dietpi image using Manjaro and it installed just fine. I thought perhaps you had fixed something, so I copied that image over to the Ubuntu install and tried again, with the same result as before. So it would appear it is something in Ubuntu that is causing the problem. The weird thing is that the previous version worked just fine.




I have the same problem:
-Download Dietpi Virtualbox image
-Install 7zr utility on my openmediavault server (debian 64) : apt-get install 7zr
-Verify if image is downloaded correct : 7zr t
-Check OK
-Extract image 7zr x
-Import appliance (.ova) in phpvirtualbox gives error:
Error reading OVA ‘/media/343fc18f-5c0c-4485-8f95-526bc7cde043/Downloads/DietPi_VirtualBox-x86_64-(Stretch).ova’ (VERR_TAR_UNEXPECTED_EOS)

Seems like .ova image is kaputt?

Anyone has the same issue?


I should have posted earlier, but there are issues with the image as follows:

Does not install in Virtualbox when at least Ubuntu 16.04 is the host, due to issues mentioned above.

It does install when Manjaro is the host, but there are issues.

  1. Incorrect network adapter… will not work with wired interface, but option to change is offered on import so it’s not a big deal.

  2. Default Keyboard is UK and likely laptop centric. I have been unable to correct it as I use a 105-Int keyboard with US-ENG. As default, I get the wrong characters when attempting to select another keyboard/language layout. Example the hyphen key gives me Beta or some such… I found the hyphen under the ?-/ key, but I have yet to get it to accept the correct combinations and have a limping keyboard.

The peculiar part is that there were zero such issues with the previous OVA. I realize that the underlying OS has been changed, but I would have thought it wouldn’t be an issue, but it appears so.

My thinking is that this OVA may have been exported from a UK centric laptop which would account for most of the issues I’m having except for the issue of using Ubuntu as a host… that one escapes me, but perhaps it’s a key issue? I’m thinking a virgin install of Ubuntu might not encounter this issue. I have the similar problems when trying to access my Odriod over SSH when I have made a new install on my machine but copied over the keys from the previous install. I get asked if I wish to delete that key and install a new one, which solves the problem.

Hi, could you please check if you would do one of the VM machine setup steps different?
Note that I used a Windows host to create the image.

  1. Is it about the “virtio” adapter that maybe does not exist on Linux hosts? Then I should switch to Intel adapter. Or simply deactivate network adapter by default. So users can activate and choose proper adapter and network type.

  2. Keyboad leyout is UK by default on all DietPi images. Use dietpi.txt to change AUTO_SETUP_KEYBOARD_LAYOUT to US respectively your desired language.

Was the last image you used (and didn’t face this issues) still Debian Jessie or already Stretch as well?

No luck after editing dietpi.txt and I checked dietpi-config to make sure keyboard and language was set there as well.

I will have a look at doing it from scratch (issues/1505) but the whole point of releasing a *.ova is to avoid all those headaches and indeed the previous itteration worked just fine.

As for the network adapter, here’s a screenshot

“Was the last image you used (and didn’t face this issues) still Debian Jessie or already Stretch as well?”

I installed mine quite a while ago and it updated until it became required to reinstall all dietpi installs, rather than update. The new OVA is having all these issues.

Did I understand, setting keyboard layout via dietpi-config and reboot did not have any effect?
If yes, could you try and paste here to output of following commands, choosing you desired layout in the GUI:

dpkg-reconfigure keyboard-configuration
invoke-rc.d keyboard-setup start
cat /etc/default/keyboard

Your VM network settings look like they should, bridged network to host interface/adapter, which allows internet and local SSH to guest, virtio virtual network adapter for guest, no promiscuous mode.
I am not sure, if my VM export includes the host WLAN adapter, that I use here during creation. I am not able to unselect the host adapter, without changing network type or completely disable. But I would keep the settings mentioned above, as they allow all kind of network you usually want. The only thing that needs to be chosen by end user, is the correct host network adapter/interface that provides internet access, if there are more than one available. Of course we can’t predict here, as it totally depends on OS etc. etc.

Are there more issues you face with this VM image?

  • The keyboard layout issue should be not related to the VM, as the methods to change are the same for all devices. So we will check separately.
  • About the default VM network settings, I am open for improvements. Would be great if you could compare the settings you need with the ones your find in our VM image.

The linked screenshot shows the results of those commands. The second command showed NO response at all. It appears for some reason that my image is using the “de” layout on the correct keyboard, even though it is set to “us” in dietpi.txt.

The link:

The network does work properly, it just asks me to select a different interface name as the one defaulted to in the image is not available on my mahcines… I only noted that this did not happen with thie older OVA.

Okay, I realized one issue with my image, will upload a new one.

I though during DietPi-Prep, at least as first run setup, “gb” will be set automatically as keyboard layout. But actually it is only overwritten, if something different than “gb” is set in “dietpi.txt”:

For easier creation I used my native “de” layout, which will then not be overwritten without changing “dietpi.txt” to something different.

But you say now that even setting layout via dietpi.txt to “us” and manually running “dpkg-reconfigure keyboard-configuration”, selecting keyboard model and language there, does both not have an effect? I just tested it here on VM and both worked well, even when accessing just via VM (so no physical keyboard attached).
Do you see any error messages during “dpkg-reconfigure keyboard-configuration”?

Does it work with:

sed -i '/XKBLAYOUT=/c XKBLAYOUT="'"us"'"' /etc/default/keyboard

and reboot?

Is there something missing in the command: sed -i ‘/XKBLAYOUT=/c XKBLAYOUT="’“us”‘"’ /etc/default/keyboard

I had to CTRL-C to get the prompt back, it never completed.

The new *.OVA still will not import into Virtualbox that is running on a Ubuntu 16.04 system. The error is as before:

Failed to import appliance /home/chris/Desktop/DietPi_VirtualBox-x86_64-(Stretch).ova.

Seeking within the archive failed (VERR_TAR_UNEXPECTED_EOS).

Result Code: VBOX_E_IPRT_ERROR (0x80BB0005)
Component: ApplianceWrap
Interface: IAppliance {8398f026-4add-4474-5bc3-2f9f2140b23e}

While I am able to import the appliance on a Manjaro Linux system, in Ubuntu, this does not work for me. Another fellow, who attempted it and who let me know about this, is also running Ubuntu Mate 16.04, so the new image you uploaded, did not make any difference with that issue. The old image made with raspbian (!!!) had no such problem. As this is two separate computers, locations and operators… it appears it is not isolated on just my Ubuntu install. I have no problems importing other *.OVA from other sources… It is an odd error.

As mentioned, the dietpi-config script was able to set the keyboard and language in the end, so it is working now.



Have you tried the VirtualBox forums? As the image works on some platforms and not on others, it seems possible it is an underlying issue with VirtualBox on Ubuntu or at least they might know if a particular option is required.

First of all, the new image is not yet online, sorry for confusion. I granted access to them for Fourdee, who needs to review and upload to: Then you will find images for VirtualBox and VMware dated 12+. March.
They contain a fix for the first run keyboard layout issue. Apologize for this, at least it worked as expected via dietpi-config.

About the import error, I just found:!topic/concerto-digital-signage/zWazrlOGz9s

It could be related to wrapping, transferring, storing on different systems/servers, unwrapping somehow.

  • First of all try to upgrade your VirtualBox to the latest version. They seem to handle this kind of “EOS” (End Of Stream) issues better with current versions.
  • If it does not help, try to extract the .ova file with 7zip and import via 3 extracted files.
  • If error still occurs, we need to check if it is related to ovf file format (I use 1.0) or something else, maybe Fourdee did something different there for the older images.

New images you created are up (thanks Micha) DietPi - Lightweight justice for your SBC!

I believe I may of used OVF 2.0 previously. Hopefully the 1.0 will fix it with older version of VirtualBox?

I downloaded the new image, same problem.

Ubuntu is updated to the latest packages in the repos and clicking “about Virtualbox” shows:
5.0.40_Ubuntu r115130

And in my Manjaro install:
5.2.8 r120774 (Qt5.10.1)

For my personal use, I have sworn off Ubuntu and switched to Manjaro, but this does not help other Ubuntu users.

I have created an account on the Virtualbox forums and will be posting some questions there. In the meantime I may remove the Ubuntu sanctioned version of VB and replace it with a virgin copy from Oracle and see if that clears things up… the only problem is finding the time.

Just a small update.

The new image installs fine in Manjaro and all I have to change at first boot is the wired interface which is dead easy to do (the correct interface is your only option!). Once up, I was able to select the correct keyboard, lanquage and timezone with no issues using dietpi-config.

Did you try downloading the deb from the virtualbox site rather than doing an apt-get? They have a 5.2.8 package or add the virtualbox rep to your sources.