dietpi-software command not opening

When I run dietpi-software command, I get the following on the screen:

root@DietPi_Server_RPi3:~# dietpi-software
[Info] Checking RootFS R/W access. Please wait…
[Ok] RootFS R/W access.
[Info] Initializing database, please wait…
[Info] Reading database, please wait…
DietPi | 02:13 | Mon 18/12/17
V159 | RPi 3 Model B (armv7l)
IP Address |

Welcome to DietPi-Software

[Ok] NTPD: time sync | Completed

and that’s it. It doesn’t do anything else. Nothing opens, no errors. I have to press ctrl+c to get back to a command prompt. I didn’t install any software recently. Also, my motioneye software doesn’t work either. Happened at the same time. I have motioneye saving videos to a 16GB flash drive, which has been working fine for months. Today I removed the 16GB drive and replaced it with a 64GB drive to upgrade the storage capacity of motioneye to save videos to. The new USB drive didn’t show up in the list under file storage in motioneye, so I rebooted the Raspberry Pi 3. When it came up, motioneye didn’t work. It says that has started in the boot up process, but doesn’t show up under htop. So I thought I would just reinstall it. That’s when I found out that dietpi-software doesn’t work. It also won’t start from dietpi-launcher. I don’t want to have to reinstall the whole system because I have a lot running on it. For example: mosquitto, apache, node-red, motioneye, webmin. Those are the main ones. I have tried to run:

/DietPi/dietpi/dietpi-apt-get_update 2

which gives me the error of no such file or directory. I found this command going through the forum, but I can’t find another example of the same problem that I’m experiencing. I’m not sure where to go from here. I’m not very proficient in Linux, but I can follow instructions. Please don’t ask me to sent an error report (I don’t know how) without telling me how to do it. I have installed Peter Scargill’s script to install a lot of the extra software I have, but everything has been working great for about 5 or 6 months. I upgraded motioneye to the latest version about a month or two ago. Any help would be MUCH appreciated. Thank you.


I have the same problem. Mine beguns when i replaced this morning a 1Tb HDD for a 4TB HDD. After that, even Plex Media Server begun to start to malfunction when I tried to delete the old content.

I’m reinstalling the whole system just now.


So please put this 16GB USB Stick back in and reboot.

Will it now work again?

If this work, please show:


DietPi-Drive Manager

DietPi-Software | User Data

What’s from 23 Sep 2015, it’s gone since Debian Wheezy has gone since 2016 with DietPi v127 …

How we should support this? Sorry don’t know what this is doing with your system …

Sorry to hear this, but it is a bad idea to simple replace a device, since modern Unix system using UUID for devices :

OK, I did this and it indeed did work. I thought when I connected the USB drive, it was only being utilized by MotionEye and not the whole system. Here is the screen shot of dietpi-drive_manager:

/boot : /dev/mmcblk0p1 | vfat | Size: 63M | Used: 23M (36%)
/ : /dev/mmcblk0p2 | ext4 | Size: 7.3G | Used: 3.9G (56%)
/mnt/EF4C-C858 : /dev/sda1 | vfat | Size: 15G | Used: 21M (1%)

Now what? How do I change a USB drive the right way? (I know how to do it the wrong way… :thinking: )

OK. Not supposed to work. Good to know. Thanks for the info.

This was only for info about what I had installed. Peter Scargill’s script is only an install script designed for DietPi (that’s how I learned about the DietPi OS). It is not an important part of my issue. I wasn’t asking for help with it, just providing info. Thanks.

So, to answer my own question of how to properly remove a drive:


Select the drive you want to remove, press enter. Then it will bring up another menu of actions that you can perform on that drive, one of which is unmount. Unmount the drive, then you can unplug it. Turn the Pi off, then plug in the new drive and turn the Pi back on. DietPi will recognize the new drive and everything should be fine. At least it was for me… :smiley:

Thanks for all the help. I hope this helps someone else.