DietPi on NanoPi Neo Air?

I tried to use DietPi on my NanoPi Neo Air. Thus i copied the unchanged image contained in DietPi_NanoPiNEO-armv7-Jessie.7z to an SD card. When it comes to setup the wifi, I always end up in something like this:

[ 151.356677] lost page write due to I/O error on mmcblk0p2
[ 151.380286] mmcblk0: error -110 sending status command, retrying
[ 151.391620] mmcblk0: error -110 sending status command, retrying
[ 151.402940] mmcblk0: error -110 sending status command, aborting
[ 151.414210] end_request: I/O error, dev mmcblk0, sector 920216
[ 151.424196] Buffer I/O error on device mmcblk0p2, logical block 98387
[ 151.424196] lost page write due to I/O error on mmcblk0p2
[ 151.424196] end_request: I/O error, dev mmcblk0, sector 920224
[ 151.424196] Buffer I/O error on device mmcblk0p2, logical block 98388
[ 151.424196] lost page write due to I/O error on mmcblk0p2
[Ok] wifi enable | Completed

\

  • Restarting networking services…
    [ 154.375121] gmac0: probed
    [ 154.383541] gmac0 gmac0: eth0: eth0: PHY ID 00441400 at 0 IRQ poll (gmac0-0:00)
    [ 154.409102] ADDRCONF(NETDEV_UP): eth0: link is not ready
    Internet Systems Consortium DHCP Client 4.3.1
    Copyright 2004-2014 Internet Systems Consortium.
    All rights reserved.
    For info, please visit > https://www.isc.org/software/dhcp/

I used three different SD cards, but the I/O error never disappeared. So I’m quite sure this is not an issue of a broken SD card.

Additionally at this point in time I was never asked for the wifi key. So the DHCP client will never be able to connect to the wifi.

Do you have any suggestions for me how i can get DietPi running on my NanoPi Neo Air?

Thanks
Thomas

Do you have any suggestions for me how i can get DietPi running on my NanoPi Neo Air?

Hi Thomas,

We are currently working on the NanoPi NEO Air image. Having a few issues with WiFi at the moment, looks like firmware/kernel issues (using ARMbian build tools). Will try and take another stab at it in the next few days.

Thanks very much - i’m looking forward to an image for the neo air. :slight_smile:

Image is now available: https://dietpi.com/downloads/images/

Great, thanks very much! :slight_smile: I’m just downloading it.

One additional question: If there are some spaces in the wifi key, shall i use quotation signs, eg:
Wifi_KEY=“this is my wifi key”

Thanks!

Thomas

Quotations shouldn’t be needed, eg:

Wifi_KEY=This is my WiFi password

Should work fine, but let us know if any issues (untested).

Hi
DietPi on NanoPi Neo Air is tested ?
Unfortunately I did not get the result. Can not connect to Wi-Fi.
What’s the solution ?

I didn’t get the NanoPi NEO Air running, too. I worked with dietpi.txt, DietPi-Config and even fiddled about /etc/network/interfaces. None of them did work. I didn’t get a working connection (both with DHCP and by adding a static IP address). So i gave up and continued using FriendlyArm’s Ubuntu (nanopi-air-core-qte-sd4g.img.zip).

Nevertheless i’m still interested in using DietPi on my NanoPi NEO Air. Are there some logfiles i can have a look into in order to provide further details? Or is there any other useful information?

Thanks!

Thanks @thomaspfeiffer
I have another problem, My PuTTy output :
Is this normal ?

I’m using this usb to ttl converter: https://www.amazon.de/gp/product/B00AFRXKFU/ref=oh_aui_detailpage_o09_s00?ie=UTF8&psc=1
I plug the USB to my Raspi and work with screen /dev/ttyUSB0 115200. Be aware of cross-bonding TXD and RXD.

Thanks @thomaspfeiffer
My TTL cable tested with FriendlyArm’s Ubuntu without problem.

Hi Thomas,

Thanks for the report. I’ve created a Git ticket for this, will take a look: https://github.com/Fourdee/DietPi/issues/640

On the NanoPi Neo Air, I tried both using SD card and flashing to the emmc with DietPi_v138_NanoPiNEOAir-armv7-(Jessie)
edited the dietpi.txt file
it still doesn’t connect to the wifi.

i tried dietpi with similar settings on raspberry pi 1, nanopi neo (ethernet ver) with USB dongles and it both works.

i also tried using armbian on the nanopi neo air, it does work fine but there’s some setting need to be done eg the wifi need to be configure to switch on, by default its off.
and so far it doesn’t auto connect to hidden ssid wifi on armbian.

i think g_serial is not running automatically
we need g_serial to run so that we can connect to the nanopi neo air through usb
since there’s no video output and ethernet, and when the wifi can’t auto connect, we can’t do anything without g_serial

Hi all,

We have a new image ready for testing, for those users who experienced WiFi issues, please see:

Edit: Image is now live: https://dietpi.com/#download

Wifi works now, thanks very much! :slight_smile:

Excellent, updated image is now live :slight_smile:

Hello,

Nice work on this one.
It would seem that bluetooth is not working?
I posted an issue on Git:
https://github.com/Fourdee/DietPi/issues/738

On the stock Ubuntu Core bluetooth works but it seems they use different drivers.(brcmhd)

Hello,
Let me ask about Bluetooth. I am working on my project based on NanoPi Neo Air, where Bluetooth has critical meaning.
Would you tell me - is Bluetooth on the board stable?
I have seen instructions from Wiki (about using Bluetooth on Nano Air) and I have seen it works. I have seen it it dozen times performed by other and it works. But my unit will send (using Bluetooth) hundreds of files, many hours, many days and the requirement is it to be sent with no troubles (security matters).
As I know, version of linux apps starting with zero (like 0.24 for obexftp) means that they are not final version, I am right? And I have red that such version shouldn’t be used in production systems? But there is not any other… (last obexftp is from year ago, no updates…).
Making real test needs me to buy more NanoPi and make long tests - that’s why I am asking here, to save my $ and time. But maybe I’m scared unnecessarily?
Did someone tested that Bluetooth in NanoPi Neo Air?