Computer fails to reboot "watchdog did not stop" "waiting for process systemd-udevd"

System Information

  • DietPi version
    G_LIVE_PATCH_STATUS[0]=‘not applicable’
  • Distro version: bullseye
  • Kernel version: Linux DietPi 5.10.0-21-amd64 #1 SMP Debian 5.10.162-1 (2023-01-21) x86_64 GNU/Linux
  • Architecture: amd64
  • SBC model: Native PC (x86_64)

System reboots on a cronjob at 6am every day and sometimes it just fails to reboot. It happens randomly maybe 1-2 times per month and I can’t SSH to the system when it happens so I had to connect a monitor and wait for the problem to happen again. Took a picture of the last output, which showed the same thing both times it happened so far:

Anyone’s got any idea what this does specifically? Checked Google but the information I found wasn’t really helping with my level of knowledge. Is it possible it’s a kernel bug as per this post? Later kernel version though.

NOTE: No USB flashdrive connected (only a USB keyboard) and there is no dedicated GPU (There was one before but I removed it a while ago)

Please enable udev debug logging to hopefully get more output when this happens:

G_CONFIG_INJECT 'udev_log=' 'udev_log=debug' /etc/udev/udev.conf

This adds quite a large number of system logs (especially at boot), so might be worth it to try triggering the issue directly with some reboots or so.

Thanks friend,

Just came here to say I still don’t have any info yet since the freeze doesn’t happen often, but I’ll report back as soon as I get it :slight_smile:

1 Like

If it somehow doesn’t freeze anymore, even better. Otherwise jep, just report back with hopefully additional logs when it happens again.

Hello again,

server didn’t reboot again this morning but the error messages seem exactly like the old one, no more info:

Shouldn’t the command have been:

G_CONFIG_INJECT 'udev_log=debug' /etc/udev/udev.conf


The content of /etc/udev/udev.conf at the moment is:

# see udev.conf(5) for details
# udevd is also started in the initrd.  When this file is modified you might
# also want to rebuild the initrd, so that it will include the modified configuration.


And I would have thought the level should be debug or info

1 Like

Ah, indeed I switched the arguments, it should have been (also corrected above):

G_CONFIG_INJECT 'udev_log=' 'udev_log=debug' /etc/udev/udev.conf

And then yes, the result should be that it contains udev_log=debug. “info” is the default, which does not reveal sufficient info, so we need debug logs.

Gotcha thanks haha! Fixed it, will report back in a few weeks/months when the problem happens again XD

1 Like