Cinnamon desktop menu - no shutdown or reboot options on system icons

Creating a bug report/issue

Required Information

  • DietPi version = latest version (downloaded today)
  • Distro version | raspian bullseye
  • Kernel version | uname -a
  • SBC model | `rpi3b+ and rpi 4b
  • Power supply used | official rpi power cubes
  • SD card used | none - using usb hard drive

Additional Information (if applicable)

  • Software title | (EG: Nextcloud)
  • Was the software title installed fresh today (actually started from scratch twice - so far)
  • Can this issue be replicated on a fresh installation of DietPi? see above
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

  1. …just try to click on the shutdown button in the menu

Expected behaviour

should popup a window with "suspend restart cancel shutdown"

as choices,

Actual behaviour

  • …just pops up a window asking you want to power off and a cancel button, but nothing works

Extra details

  • …If I could find out where the config files for this session button are I could compare them to a Linux Mint
    installation on my laptop and see what is different/missing.

Hmm we don’t offer cinnamon desktop as an installation option, I’m not sure if we can help you here.
Did you try to add an shutdown applet by yourself, via right-clicking the panel?

it’s not an install option correct.

@StephanStS create a blog post a couple of months back. Maybe he know as he tested all these desktop systems.

1 Like

Yes I did, And it showed the proper choices, they did exactly nothing. The interesting thing is that installing cinnamon-desktop-environment on a Raspian Bullseye base works just fine. So it is definitely something in Dietpi. I suspect that the repository that Dietpi is downloading from may have a incomplete/corrupted copy of the cinnamon-desktop-environment files.

We use global Debian apt package repository. We don’t have own repository.

OK, I did a fresh install and found something that I had missed. Namely that the shutdown options were also non functional in the lightdm boot screen, so it appears that the problem is more likely in the autoboot install of lightdm. Just to verify what is happening I did another fresh install but installed mate desktop using the dietpi-software option. Then did the dietpi-autoboot 16 thing. Rebooted and the shutdown options worked just fine in both the lightdm boot screen and in mate. So I uninstalled the mate desktop using dietpi-software. Then I installed cinnimon-core and the shutdown options are now working in both the lightdm boot screen and in cinnamon. So it would appear that something is missing when you do the dietpi-autoboot 16 command before installing cinnmon-core. Oh well, I got the desktop I wanted up and running even if it did take a few strange steps to get it working.

@Gale: Thank you for your investigations.
I could reproduce this behaviour:
grafik

Could you please execute a dietpi-software reinstall 6 and reboot the system?
In my case this helped:
grafik

If this also helps at your site, I will update my blog post Discover exciting X11 desktops for your DietPi.

As for the Cinnamon install, I did find oone other set of problems.

The default cinnamon install does not change the gpu_memory splits in /boot/config.txt.
should be (based on a mate install):
gpu_mem_256=76
gpu_mem_512=76
gpu_mem_1024=76

The other problem is that it does not put a video driver entry in config.txt which causes cinnamom to complain about the video.

dtoverlay=vc4-kms-v3d (if you are using an hdmi monitor)
or
dtoverlay=vc4-fkms-v3d (if you using a non hdmi monitor)

Now I am left to work 0n my last problem of synaptic locking up when you try to run it. But that is in another thread.

And what about the missing shutdown dialog entries? Are they present yet?

That is right. Those are set when a desktop is installed via dietpi-software but not for manual desktop installs and not for X11 installs. Probably we should instead set those defaults whenever X11 is installed.

Those are present here without an X11 reinstall, when trying with minimal/core install. Also, the cinnamon-core package install does not replace/uninstall anything of the previous X11 install, so the reinstall should be a no-op doing exactly nothing. Tested again with cinnamon-desktop-environment which has the same result. Those shutdown options are generally provided by the upower package. While this is not installed with X11, it is a dependency of cinnamon-core

Tested on Bullseye x86_64 VM. Can you reproduce this on RPi only?

Until we found the reason and proper solution for this, I suggest to adjust the blog post to not first install X11, then the desktop, then reinstall X11, but instead install desktop, then install X11, just to avoid the same step two times :slightly_smiling_face:.

On the Pi once I did the extra step fo dietpi-software reinstall 6 the shudown dialogs worked properly on both the lightdm boot screen and in cinnamon. Just for the heck of it I will do a fresh install on a spare usb hard drive tomorrow but will try to do a manual install of upower after the initial deitpi-software install 6 run and then continue on and see if cinnamon installs properly. Just use it long enough to see if the lightdm boot screen and cinnamon shutdown windows are working properly. I had noticed that upower was installed with mate but didn’t check with the cinnamon imstall. But if removing mate did not remove upower that could be why installing cinnamon that would explaain why everything was fine that time.

@MichaIng: Changed the blog post and tested it positive for GNOME, Plasma, Cinnamon, Budgie, Enlightenment.

2 Likes

Try to skip that. Just install Cinnemon and verify that this pulled upower in automatically as dependency. If not, which package did you actually install? Both options from the guide do pull upower in. Probably it was a temporary bug among the packages, which has been solved in the meantime. As said, I tested everything, and no additional package or any reinstall was needed.

@Gale Ot would be nice if you use the commands from the blog post to ensure that this is error free. Otherwise I would like to optimize the blog post with a different procedure.

I did a from scratch install of dietpi and cinnamon on a spare disk and used the blog proceedures and everything worked properly. I admit that my normal way of doing an install did not have me installing the desktop before adding the xserver-xorg packages .
I have three disks that are used to test out various things, so there is no problem doing a wipe and reload for testing things.

1 Like

Indeed, although it shouldn’t make any difference. Could be tested again with installing X11 first and the desktop afterwards. As said, on my test it worked, and based on the fact that (at last now) either installing the one or the other first does not lead to different packages being installed, it shouldn’t make any difference.

Next day or so I will do another clean install of dietpi and cinnamon using my normal sequence (xserver-xorg, cinnamon, boot type) and see what happens. This will also give a clean board for continuing my troubleshooting of my synaptic going to 100% cpu load as soon as you try to get it to do anything. But that is on another thread.

I have the following results:

  • If you execute simply apt install cinnamon-core && dietpi-autostart 16 and reboot, the window manager is missing. I.e. you can login but only the wallpaper appears, no menu bar is present
  • If you then execute dietpi-software install 6 and reboot, all works fine (Menu bar is present and shutdown dialog is o.k.)

############

  • If you execute dietpi-software install 6 && apt install cinnamon-core && dietpi-autostart 16 and reboot, login and menue bar is ok, but shutdown dialog is not ok.
  • If you then execute dietpi-software reinstall 6 all works fine

############

  • If you execute apt install cinnamon-core && dietpi-autostart 16 && dietpi-software install 6 all works fine

’ ~~~~~~~~~~~~~~~~’

Result: Order does matter. :slight_smile:

Remark: This testing with Proxmox VMs (cloning them all the time) is much quicker compared to generate SD cards.

1 Like