Can't install OS; Chicken and egg problem! Please help!

Hello! I am following this tutorial (https://www.instructables.com/FeatherQuill-34-Hours-of-Distraction-Free-Writing/) to make a device to write on. I have a Raspberry Pi Zero2W, and an E-Paper display with HAT (https://www.waveshare.com/wiki/6inch_HD_e-Paper_HAT). I have successfully wired the display into the Raspberry Pi, but now I have a problem. You will see that the display requires some libraries to be installed, but how can I do that without an OS or display? It seemed like a chicken or egg problem. So I then tried to install DietPi. Since I didn’t have a screen, I tried to set it up for wifi, and changed the appropriate fields in the .txt files so it would connect to my wifi on bootup. But I never found the IP Address, and I waited for half an hour. How can I find the IP Address so I can use the terminal remotely? My plan is to then install DietPi, then install the libraries to use my display. Please help! Thank you!

Can you share your dietpi-wifi.txt. Pls mask WiFi password. As well pls share dietpi.txt.

Do you have another Linux box where you could connect the SD card to using some USB SD card connector? This would be helpful to access some log files on the ext4 partition of your SD card. (Windows is not able to read ext4)

Certainly. The wifi name is ‘caleb’. The password is something else, but I just put ‘password’ for here.
I only have a Windows PC, unfortunately :thinking:
dietpi-wifi.txt (2.9 KB)
dietpi.txt (14.7 KB)

just to be sure, you added your WiFi credentials to dietpi-wifi.txt before first boot?

# Entry 0
# - WiFi SSID: required, case sensitive
aWIFI_SSID[caleb]='myWifi'
# - WiFi key: If no key/open, leave this blank
aWIFI_KEY[password]='myPassword'

Quite hard to do any debugging without screen or access to the ext4 partition. The RPi Zero2W has a mini-HDMI Typ C port. Using a appropriate HDMi cable should allow to connect a normal screen.

I stuck in the SD card once and powered it on, without having filled out the wifi info.
So, let’s just say that 1234 is my wifi password. Would that be like this?
aWIFI_KEY[1234]=’’
Or does it go after the ‘=’?
aWIFI_KEY[0]=1234’’

Also, what is the ‘myWifi’ part after the ‘=’? What should that be? The name of my wifi is ‘caleb’

I can connect the RPi to a TV using a mini-HDMI to HDMI cable? I do not have any monitors; only a TV

I just checked; I don’t have a mini-HDMI cable, and can’t get one, xD

WiFi credentials would need to go between the single quote. You placed them incorrectly :slight_smile:

In your case it would be

# Entry 0
# - WiFi SSID: required, case sensitive
aWIFI_SSID[0]='caleb'
# - WiFi key: If no key/open, leave this blank
aWIFI_KEY[0]='yourPassword'

But this is working on first initial boot only. For a new try, you would need to flash the SD card again and adjust the 2 config files.

And you can connect every screen as long as you have the correct cable. So TV should be fine as well.

Oh, okay! I will try to boot it up again with a fresh flash and with those new credentials and see if I can find the IP Address.

Hmm… I did so, and checked for IPs, but found nothing :thinking:

Did you checked on your router/access point for failed login attempts?

I am using a phone’s mobile Hotspot… That’s my router :rofl:

Do you use some complex password with special characters? On The mobile phone, you don’t see any connect device?

The password is simple, something like ‘12345’. I can see connected devices, but didn’t see the RPi. I triple checked the info, and it is correct

I’m not sure how to debug this further without access to the ext4 partition or a screen attached. Because we don’t know whats going on with your system. You could try to connect to some other WiFi network to see if it behave some. Or try to change hotspot settings like channel or bandwidth.

I will try with a different wifi and see what happens! Thank you so much for all the help so far!

It worked! The problem was a noobie problem :roll_eyes: I powered the RPi on, THEN inserted the SD card. I should have put in the SD card first, and then boot. This was a total noobie mistake, I am sorry for that! Thank you for your time! I did have the wifi info in the wrong place, and you helped me with that! Thanks!

I just had one quick question, as something isn’t working. I ran through the DietPi config, but at the end, it failed to do the update. Nothing is wrong with the internet, but it keeps failing after multiple attempts. It says this:

APT upgrade
│  - Command: apt-get -qq upgrade
│  - Exit code: 100
│  - DietPi version: v7.9.3 (MichaIng/master) | HW_MODEL: 3 | HW_ARCH: 2 |
│ DISTRO: 6
│  - Image creator: DietPi Core Team
│  - Pre-image: from scratch
│  - Error log:
│ E: Failed to fetch
│ http://raspbian.raspberrypi.org/raspbian/pool/main/c/curl/curl_7.74.0-1.3%2b
│ deb11u1_armhf.deb  Cannot initiate the connection to
│ raspbian.raspberrypi.org:80 (2a00:1098:0:80:1000:75:0:3). - connect (101:
│ Network is unreachable) Could not connect to raspbian.raspberrypi.org:80
│ (93.93.128.193), connection timed out [IP: 93.93.128.193 80]
│ E: Failed to fetch
...

I guess this is the a fault of raspbian.raspberrypi.org, just try again later.

try to disable IPv6. This can be done within dietpi.txt before boot, or on dietpi-config network options. And yes, it could be a temp issue.

Okay, I have tried it multiple times now, days apart, but to no avail! I booted again, and in the dietpi.txt I set IPv6=0
It still shows the same thing; Unable to get that update.
Is there any way to just skip that? I only want to run WordGrinder on my RPi, and nothing else, so I don’t think I’ll need it.