Can't get Dietpi to boot on ODROID N2+


I’m trying to install Dietpi on ODROID N2+. I have the 2GB RAM model. I correctly flashed the image to the eMMC using Win32disk imager.

But the image doesn’t boot. I am having this screen:

It is desesperately trying to download something, I found no information on what it is. I found no additional instructions on Odroid nor Dietpi docs. After trying to download several times, it just stops and doesn’t boot into dietpi.
Could someone help me ?
Thanks in advance and have a great day

Looks like system is trying to use PXE boot. Means it is trying to boot from a remote network location and not from local storage

Strange, do you have an idea why it would try booting on network by default ? Do you know how I can make it boot on the eMMC ? CoreELEC works fine and boots directly on the emmc.

What system is? Your router? Not sure if intended, but it is offering a TFTP server. and your system is reacting on it.

Hoenstly I’m not sure why PXE boot is enabled on your system. Is there any other boot loader like Petitboot? is my router, yes.
I don’t intend anything other than just booting dietpi on the odroid’s emmc. I flashed the iso from dietpi directly on the odroid’s emmc, I didn’t install anything else. There is no petitboot or equivalent.

did you tried booting from SD card?

Maybe the boot select switch on the N2+ is not set properly.

Yes the switch needs to be at “MMC”. PXE is usually a fallback if eMMC and SD card boot does not work, which is indicated at the first two lines of your screenshot.

Which eMMC module do you use? The one from Hardkernel or another one? I remember there were issues with some eMMC modules on Odroid.

In case, did you try to boot another image, like Armbian or Hardkernels Ubuntu image?

Another test could be to use Rufus to flash the .img file to the eMMC.
Other test: Try to run DietPi from an SD card to start investigations from a running state.

Hi @MichaIng and all;
I seem to have the exact same issue with the newest image for Odroid N2+…

Any ideas ?

Tried it with Rufus and Balena Etcher ; both times the same result. It gives an error : failed to load /boot/image and then tried to find a MMC 2 after which is starts to load TFTP

To be clear on this; I have a 128GB eMMC from Hardkernel. I think it’s an orange one; it came with Linux installed but I flashed DietPi on it.

It’s all brand new.

Did you tried booting of SD card?

Have not tried that yet; have only tried the eMMC with multiple flash tools.

I’ll try that and will let you know how it goes.

Obviously would like to use the eMMC because that’s way more stable / longer life expectancy :slight_smile:

I’m guessing this might be something similar as half a year ago with the bootloader issues, but I’m no expert on Linux images so I’m kinda lost in what the issues could be.

Thanks for the help! :pray:

Update: I tried with a SD card and no problems there; instant boot and configuration was easy and as expected.

Any ideas on why it wouldn’t work with eMMC ?

can you connect eMMC and boot of SD card? Does it boot? If yes, can you check

lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
1 Like

It boots without any issues from the SD card, when the eMMC is also connected.

This is the output for your command:

lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
NAME FSTYPE LABEL   SIZE RO TYPE MOUNTPOINT PARTUUID                                                                                        UUID
│                  29.5G      0     disk
     ext4          29.5G  0 part /          43afdce0-01   5ea3ba0e-91fb-46ab-986a-7093aadd6682
│                 116.6G  0 disk                                                                                                           
     ext4         490.6M  0 part            43afdce0-01   5ea3ba0e-91fb-46ab-986a-7093aadd6682
                      4M  1 disk                                                                                                           
                      4M  1 disk

If your system runs well from the SD card, you could go through this blog post: Running DietPi from an USB stick or an onboard eMMC.
I assume you will end with a simple dd if=/dev/mmcblk0 of=/dev/mmcblk1 bs=1M status=progress to copy your SD card contents to the eMMC.
Then reboot without SD card (don’t forget to change the boot switch to eMMC) and resize your /dev/mmcblk1 via dietpi-drive_manager.

1 Like

I will definitely try this.

I’m assuming I need to format the eMMC first, before doing the dd command? Or will it just overwrite the whole disk?


Flashing the DietPi image to eMMC module directly leads to the same result and should be preferred. We had issues with the Armbian bootloader booting from some eMMC modules in the past, but switched to a different U-Boot build then which solved the issue. Very strange that with same eMMC I use it again does not work :thinking:.

Probably we can try again the recent Armbian U-Boot build, but I fear that still causes issues with the non-Hardkernel eMMC modules :smile:.

1 Like