Backup to Synology NAS

Hi All,

Having had my fair share of reinstalling things on my pi, I’d like to take advantage of the dietpi-backup feature, but seems I’m running into permissions issues, similar to this link.

I have created a new shared folder on my Synology NAS and enabled NFS and set this to my pi’s IP address, but comes back with the similar errors from the link above.

I did try backing up to an existing samba share, but this just throws an error about CIFS.

In the other thread Joulinar said in the last post that this worked when he tested on a Synology NAS, so curious to know what I’m doing wrong? :cry:


you would need set some specific values on your Synology

as well a similar question

Personally I tested it this week

Yes SAMBA is not supported as SAMBA did not support file system permissions and sym links

Perfect, turning the squash off did the trick :smiley: Oddly enough, I had just done that prior to your post, but hadn’t tried it out as reading the forum for other things to try

yep such a small nasty setting and so hidden inside the Syno options

I’m going to post this here, since it might be searched again, but one of the thing I finally discovered today see relevant issue on github is that I had NFSv4 support enabled in DSM on my Synology. Disabling it made everything working and smooth !