AdGuard Home | Auto-Upgrade Failure

Required Information

  • DietPi Version:
    • G_GITBRANCH=‘master’
    • G_GITOWNER=‘MichaIng’
  • Distro Version:
    • bullseye 0
  • Kernel Version:
    • Linux NetworkPi 5.15.61-v8+ #1579 SMP PREEMPT Fri Aug 26 11:16:44 BST 2022 aarch64 GNU/Linux
  • SBC Model:
    • RPi 4 Model B (aarch64)
  • Power Supply Used:
    • Official Raspberry Pi Power Cable
  • SD Card Used:
    • SanDisk Ultra 16GB

Additional Information

  • Software Title:
    • AdGuard Home
  • Was the software title installed freshly or updated/migrated?
    • Freshly Installed
  • Can this issue be replicated on a fresh installation of DietPi?
    • Unknown

Steps to Reproduce
On v0.107.14 of the Web UI, click the “Update Now” button on the notification banner at the top of the screen.

Expected Behavior
Update from v0.107.14 to v0.107.15

Actual Behavior
Failure to Update AdGuard Home: “Auto-update failed. Please follow these steps to update manually.”

Extra Details

  • Screenshot of Update Failure Attached
  • The currently installed version (v0.107.14) has an issue where users could not clear the “Query Log” or “Statistics” which is what triggered this new update (v0.107.15) to be pushed.
  • I have AdGuard Home running on a Raspberry Pi at a different house which was running the version prior to v0.107.14 (I am not sure of the exact version), and I was able to auto-update to v0.107.15 without any issue - so I assume that v0.107.14 is what is causing the auto-update failure.

My question is pretty simple – should I follow the “Manual” update procedures as suggested, or simply start with a fresh installation of Diet Pi, then install AdGuard Home? I attempted to reinstall AdGuard Home via dietpi-software reinstall 126, but it reinstalled v0.107.14 instead of the updated version (v0.107.15).

did you noticed the notification during reinstall??

[ INFO ] DietPi-Software | AdGuard Home executable "/mnt/dietpi_userdata/adguardhome/AdGuardHome" already exists. Download and install steps will be skipped.
 - If you want to update AdGuard Home, please use the internal updater from web UI.
 - If you need to reinstall (e.g. broken instance), please manually remove the executable "/mnt/dietpi_userdata/adguardhome/AdGuardHome" and rerun "dietpi-software (re)install 126".

therefore, try following

rm /mnt/dietpi_userdata/adguardhome/AdGuardHome
dietpi-software reinstall 126
1 Like

Nope, I did not see that - but it absolutely worked!

If I might make a suggestion to add that piece of info to the AdGuard Home info on the Diet Pi Software webpage (DNS Servers Options - Docs).

Thanks again - will make sure to read through the CLI output next time.

preferred way is to use AGH UI to update. Therefore, we don’t list other options on our online docs. :wink:

Makes sense! Thanks again!

Sorry, so web UI should be the preferred way? I checked the docs and it says to use it, meanwhile I got the same error as OP. My dietpi OS is a fresh install from 3-4 days ago and this is the first update of adguard home I would do, but it’s impossible currently.

So in this case, it’s required to ssh into it and use terminal for the update?

Yes, we usually recommend using application vendor own update function if available.

You can have a look to AGH logs. Maybe it will give a hint on why the own AGH update is failing.

journalctl -u adguardhome

They also mention in their docs to update manually if the update via web UI fails.
For this you have to gain access to a terminal somehow (SSH or attach a keyboard and monitor)

1 Like

It seems that the error I was speaking of (where users aren’t able to execute certain functions through the web UI like clearing the Query Log) is also the cause of the Auto-Update Failure.

But to @bitpi3, doing what was instructed in the above post remedies the situation very nicely and doesn’t require a complete re-setup since you aren’t touching the YAML config file. Took all of 2 minutes to complete and everything was back to normal. But one thing to consider is the device’s DNS server…specifically, make sure that the device’s (the device running AdGuard Home) DNS is directed toward an external IP address like Quad 9 or Cloudflare, otherwise the re-install would fail.

Getting [error] POST /control/update: only application/json is allowed

Seems like it’s related to this github issue, UI errors: only application/json is allowed | 415 · Issue #4970 · AdguardTeam/AdGuardHome · GitHub but I don’t see the fix for it (not considering edge version).

Is there a way to fix this without reinstalling the application, as I wouldn’t want to go over the process of setup again?

You won’t need to re-setup anything if you follow the instructions in post #2 because you aren’t deleting the config file (which is AdGuardHome.yaml).

Here is what was posted in post # 2. This is exactly what I did and I did not have to re-complete the setup process at all. And it only took 1-2 mins to complete.

rm /mnt/dietpi_userdata/adguardhome/AdGuardHome
dietpi-software reinstall 126

Yes, that’s the way to go to overcome the issue on AGH side.

1 Like

Awesome, thank you guys! At first it showed the old version and the update button, but after rebooting RPi completely, it’s showing the new one.

Greeting, i got the same problem today with AdGuard Home v0.107.16 failing to autoupdate. I have done the step in post #2 but the ADH still failing to update automaticly and refering me to use the manual update.

Any tips?

The manual update in the latest version is now also bugged, according to this:

So instead of reinstalling via dietpi-software you would need to download the beta branch manually, extract it and place it in /mnt/dietpi_userdata/adguardhome/AdGuardHome, I guess.
Some more info about manual update can be found here:

Or you wait for the next stable AdGuard release (where this is hopefully fixed), then it should be working again via dietpi-software.

Yeah wait for the next stable release of AGH. Just watch their GitHub repository and once a new version has been released, follow the steps above.