32bit OS for RPi Cam Web Interface

I’d like to run RPi Cam Web Interface on a Raspberry Pi Zero 2.
After installing the latest dietpi image, the software option wasn’t available.
I tried to install it manually (dietpi-software install 59) and it said “Software title (RPi Cam Web Interface) is not supported on aarch64 systems”.
So I thought it would be a good idea to install a 32bit version of the OS.
Is this supposed to work and are there still recent dietpi images for 32bit?

you simply can use the image for RPI1 and Zero (armv6)

Thanks, I already tried armv7, but not armv6 :sweat_smile:
Now I’m just struggling with the timelapse conversion to video file, which does not want to work :man_shrugging:

Dunno what you tried so far, but with ffmpeg this should work:

ffmpeg -i input.mp4 -filter:v "setpts=0.5*PTS" output.mp4

0.333*PTS would be 3x speed / 33% of original length,
0.5*PTS would be 2x speed / half lenght.
0.667*PTS would be 1.5x speed / 66% length and so on.

If you start a timelapse (button in web interface), it captures a series of images, which you can convert to a video file afterwards (button in web interface).
And this function does not work for me, yet.

Thanks anyway.

You can also use ffmpeg to make a video out of images, if the cam interface does not work for that.

1 Like

links for howto’s and stuff would be nice :wink:

Also, doing a search…saw that the RPiZero2 has issues with ffmpeg on 32bit builds

You can put a RaspiOS ARM64 build on the RPiZero2…not sure if it can convert to DietPi or not with the script.

I know it works, I have 64bit running on one in my closet right now

Ah crap…disregard…I have a straight debian11 arm64 running

warhawk@RPiZero2:/etc $ hostnamectl
   Static hostname: RPiZero2
         Icon name: computer
        Machine ID: *
           Boot ID: *
  Operating System: Debian GNU/Linux 11 (bullseye)
            Kernel: Linux 6.1.21-v8+
      Architecture: arm64

I know the script will convert straight Debian…

To the op…I found this howto/walkthru that might help
Ah crud!

IMPORTANT BULLSEYE Note: Bullseye OS has replaced the camera stack which stopped the raspimjpeg working. Legacy camera support should be enabled. Do this within raspi-config under Interfce. If this shows just “Enable camera” then update raspi-config itself from its menu item. The interface option should now show enable Legacy camera support. The install.sh script will detect a Bullseye OS, set the right PHP version and create a missing directory needed by this software to run. Only the 32 bit OS version is supported. The 64 bit OS will not work.

Might look into Motion-Eye…another “Webgui” tool for cameras

oh snap…there is also mjpg-streamer