Z83 and DietPi

Just setting up this Christmas present and very impressed.

So far Emby-Server running stably with Mono

Tonido installed with one addition step - I had to install libpng12-0_1.2.50-2+deb8u3_amd64.deb downoaded from Jessie rep manually. And a big bonus is the Windows sync client works.

Syncthing working fine.

Wifi doesn’t work - haven’t tried audio or bluetooth.

Hardware transcoding using Emby-Server not working (given this device has Intel graphics this may become possible?). In fact streaming 1080p video files does not work as well as with my XU4.


Hi John,

Excellent, great to hear :slight_smile:

You know more than I do in regards to hardware transcoding :smiley:, not something i’ve had a chance to really dig into yet.

Hi John,

very nice Christmas present and good to read you have so much fun with it.

Can you please share a link to your device with us? Thanks.

We wish you and everyone a merry christmas by the way.


Hi K-plan,


This was the one I bought but at $87 US (price has gone up, but many similar models available).

When you consider this price includes power supply, 32 MB eMMC on board, Windows 10 license and postage - good value. Quality is another matter, time will tell.

But nice device.


Hi John,

thanks for the link. :smiley:


Yep, i found the plastic case is a little too “plastic fantastic”, however, the PCB quality appears top notch.

The beelink AP34 has a metal case, although, its pretty much the same inside all these devices, minus any CPU changes.
Misses is using one for main PC:

That’s a higher spec model than the one I have. Interestingly the cost of a “Linus” model and a Windows one is the same so they are not charging for Windows licence? I seen similar up to i7 on Aliexpress at good prices.

I briefly tried out the my one with Windows seemed quite usable. Extracted to Windows key to possibly transfer to a desktop I’m planning to build.


I just want to report that the newest 6.1 has allowed me to remove an Odroid XU4 form acting as a file server/plex serevr & a Tinker Board from Torrent server/Sickrage box. The Z83-II is doing all the above jobs and is better at Plex then the XU4 which will from time to time bog down. Nice job :slight_smile:

Yep, I found the same, great little board the Z83-II, highly recommended.

I purchased an Intel Z8350-based mini PC and noticed an immediate 2.5x transfer speed improvement when syncing two external hub drives via the USB 3.0 port vs the USB 2.0 ports on the Odroid C2. These Z83 boxes are an excellent choice to install DietPi 6.x on. Great work!

Apparently some (all?) of these Z83 boxes have a hidden internal USB port that you can use to install a hidden WiFi adapter or add extra storage with a USB drive. See the video below:


I haven’t opened my one to see if it has an internal USB socket but I don’t have a VGA socket as the one in the video does, so not all of these can be the same - or maybe some haven’t soldered on the VGA socket.


After reading this thread I was thinking of getting one of these but now I’m wondering how they compare to the upcoming RK3399 based SBC’s (ROCKPRO64 and Odroid N1).

Any thoughts on whether the RK3399 would perform as well as the Z83-II?


I know Fourdee has one hopefully he’ll chip in here.

This gives some info on the N1:



I believe the N1 would be slightly faster, but also more expensive than the Z83, if I’m not mistaken.

The Z83 is great value when you consider that you don’t have to buy anything extra such as PSU, case, SD, cables. And free postage on ALiExpress.

I got myself a Z83-II too. Nice little machine.
Dietpi is working fine just cpu temp. seems to show 0c 35F “who put me in th freezer”or something lol.
Either than that, shame internal sound card doesn’t work …had to use a usb one for shairport sync (which btw doesn’t show on optimized software list on x86 for some reason like it used to on my Tinkerboard and pi3).

And I’m also struggling getting CUPS working with HPLip .but that’s not q diet pi topic heheh

Have you got wifi working?


Didn’t even messed or try to use WIFI to be honest. I only need ethernet… Sorry :stuck_out_tongue:

Regarding CPU temp.
If I use ls-sensors temps display “fine”