XU4 - qBittorrent no longer starts - IO error

Creating a bug report/issue

Required Information

  • DietPi version | v8.13.2
  • Distro version | Bullseye
  • Kernel version | Linux Server 5.4.225-odroidxu4
  • SBC model | ODroid XU4
  • Power supply used | 5V 6A
  • SD card used | Sony Micro-SDHC 32GB, Class 10

Additional Information (if applicable)

  • Software title | qbitttorent
  • Was the software title installed freshly or updated/migrated? No
  • Can this issue be replicated on a fresh installation of DietPi? Yes
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | 073c3915-49f7-44c2-b0e7-49e84357cb8f

Steps to reproduce

  1. Start qBittorrent

Expected behaviour

  • Start qBittorrent as normal

Actual behaviour

  1. Start qBittorrent
  2. Exits after a few seconds, no dialog displayed

Extra details

It appears that under the qBittorrent systemctl service, it gives out an error:

'Server qbittorrent-nox[566]: Could not create required directory '/home/qbittorrent/.cache/qBittorrent/'

That directory was set to 755, changed it to 777, but it still has the same issue.

I get this error message to stdout when qBittorent quits:

ICE default IO error handler doing an exit(), pid = ####, errno = 32

Any idea what I can do to fix this?


I tested the installation on my NanoPi R5S without issues. Are you able to create the directory manually as user root?

mkdir -p /home/qbittorrent/.cache
chown -R qbittorrent:dietpi /home/qbittorrent/.cache

I’m being silly, I didn’t notice the weird path, while taking a glance at the error message I assumed it was pointing towards my user’s home folder. :man_facepalming:t2:
Any ideas why it points to that path? I don’t remember it having this issue previously.

Also, tried creating the path, but it still quits in the same way, same error messages on the systemctl service.

did you restarted the service after creating the path?

Well, it’s the home directory of qbittorrent user, who is running qbittorrent app. Therefore path is fully correct.

That is news to me, which is quite strange considering that there were no updates to qBittorrent since last starting it.

Okay, restarted the service, made sure everything under /home/qbittorrent is owned by the said user, and the service appears as “Active” now.

But when starting qBittorrent (starting it graphically through the DE BTW), I still get the same error… qBittorrent quits after 1-2 min of loading, the window closes, and I get this to stdout in a terminal:

ICE default IO error handler doing an exit(), pid = ####, errno = 32

I forgot to specify this error earlier, will amend the first post.

Searching for this error doesn’t bring up anything useful related to qBittorrent

can you check for kernel error messages?

dmesg -l err,crit,alert,emerg

Here you go:

$ dmesg -l err,crit,alert,emerg
[    0.017241] CPU4: Spectre v2: firmware did not set auxiliary control register IBE bit, system vulnerable
[    0.018766] CPU5: Spectre v2: firmware did not set auxiliary control register IBE bit, system vulnerable
[    0.020217] CPU6: Spectre v2: firmware did not set auxiliary control register IBE bit, system vulnerable
[    0.021667] CPU7: Spectre v2: firmware did not set auxiliary control register IBE bit, system vulnerable
[    4.660779] exynos-adc 12d10000.adc: IRQ index 1 not found
[    4.782068] OF: graph: no port node found in /soc/hdmi@14530000
[    4.785787] dwc3 12000000.dwc3: Failed to get clk 'ref': -2
[    4.794161] dwc3 12400000.dwc3: Failed to get clk 'ref': -2
[    7.269463] cgroup2: Unknown parameter 'memory_recursiveprot'
[    8.551945] proc: Bad value for 'hidepid'
[    8.946492] proc: Bad value for 'hidepid'
[   10.265112] sd 0:0:0:0: [sda] No Caching mode page found
[   10.265138] sd 0:0:0:0: [sda] Assuming drive cache: write through

Seems to be only stuff from the beginning of the boot process, and nothing that would seem relevant to qBittorrent :thinking:

can you reboot the system and try to access qbit afterwards. Once hit by the error, check logs

journalctl -u qbittorrent

Nothing much going on unfortunately:

$ sudo journalctl -u qbittorrent
-- Journal begins at Sun 2023-01-15 23:00:49 EET, ends at Sun 2023-01-15 23:42:08 EET. --
Jan 15 23:00:55 Server systemd[1]: Started qBittorrent (DietPi).

I’m guessing it would be worth asking on their bug tracker directly, but given that this is quite an old version of qBittorrent, not quite sure if they would be willing to look into it much.

That’s the one available on official Debian apt reposity. Debian -- Package Search Results -- qbittorrent-nox

You could try to remove Qbit completely and try a new install. At least I’m not able to replicate the behaviour. On my 2 test systems, Qbit is working fine without issues.

I’m not using the nox version though, I’m using the GUI version instead.

I autoremoved the qBittorrent package, restarted, installed it again, but still the same. :confused:

You don’t use dietpi-software to install Qbit?

From what I know, dietpi-software only installs qbittorrent-nox, right?
To me that’s not useful, since I need the full GUI as the web interface doesn’t really cut it.

yes we install nox version (web interface). However if you install Qbit yourself, I’m not sure how we could help.

Tried the nox version, doesn’t seem to load any of my torrents up.

EDIT: After some more digging, I managed to get it to run (albeit not in the best way) after clearing out the configuration file of qBittorrent. This of course wipes all settings and such, but at least it runs. Saving the settings and starting qBittorrent again causes it to close/crash again.
I’ve had similar problems with it on a different distro on my SBC with a newer version, so I’m guessing this is a very pesky bug in qBittorrent that won’t be sorted too soon. I created a bug report to them with that, but it didn’t go too far.
So I’m guessing to solve this issue, I would need to use a different torrent client, but transferring all the torrents from one client to the other would be a PITA.