XU4 kernel 4.9

I see from Odroid forum this has been released - will this be available for DietPi?


If not tempted to buy a second one with recent price drop:


Main reason is I read that video transcoding has improved a lot.


After reading the Odroid forums all evening I decided to manually install the 4.9 kernel from here:


But - unbootable system. Restored from backup and all working again.

Hopefully Fourdee will have some insight into this.


Hi John,

It looks like the 4.9 kernel is still in early devolpment/testing stage. I think the best thing to do would be to report any issues directly to this thread: http://forum.odroid.com/viewtopic.php?f=146&t=26007

I was unaware Meveric released the 4.9 kernel, let me test it on my system. I’ll also message Meveric so he can see your results.

Hi Fourdee,

I was possibly a bit hasty last night as I didn’t want to go to bed and leave a broken system - hence the restore.

I missed the step of attaching a monitor to see what was going on would you believe!

I assumed it wasn’t booting - nothing on router, no SSH, no cloudshell display.

I’ll try it again tonight.


Tried again this time with monitor attached (kicking myself for not doing this yesterday) - device booted but no LAN. Hard to do anything without this.


Gutted lol.

The following may be helpful for debugging this (and reporting it to Odroid as an issue):

dmesg | grep eth

Or save to boot, eject SD and read from PC :smiley:

dmesg > /boot/debug.txt

HI Fourdee,

I’d love to get this kernel working but restoring to an eMMC is such a hassle - having to take Cloudshell case to bits and getting a PC to read the eMMC to restore is hit or miss. Done it twice now. Maybe a better idea is to set up a dual boot and experiment on an SD.

Or buy a second XU4 :slight_smile: Given I have an unused case and PSU having upgraded to Cloudshell this is tempting :slight_smile:


Aye, must admit, the price reduction is very tempting :wink:


Any luck with the 4.9 kernel on the XU4? solving ethernet issues

@johnvick did you tried wlan maybe that works for you and you’re be able to run the 4.9 kernel


Today meveric released a new compile for the kernel http://oph.mdrjr.net/meveric/kernel/XU3/4.9.x/

I’ll try it again later today and let you know.

In this thread running at the odroid forum, they mention this exynos5422-odroidxu4.dtb flattree file. I wonder whats the difference between the xu3 and xu4 versions. Is the ethernet performance gain related to it? (once it contains the specifics about the hardware).

Maybe it is easier for you to grab a sd-card to test/debug the upgrade, and keep your eMMC safe

I may just do that - but not right now having had a pig of a day yesterday installing a new eMMC and restoring from backup. All working now but I don’t feel inclined to dismantle the device again. May do at the weekend. I’ve been watching the Odroid forum with interest too.