XRDP & Odroid N2 - Can't Interact


I recently purchased an Odroid N2 and flashed DietPi to it. No matter what, I can’t seem to interact with anything via XRDP. Mouse and keyboard strokes don’t register whatsoever. I have tried multiple desktops to the same experience.I even tried RDP’ing from another machine and had the same experience.

If I hook up peripherals directly to it and launch the desktops, everything works fine.


what exactly is your issue? Are you able to do some screen shot or to describe it a little bit more? Are you able to login using RDP? Did you as well installed TigerVNC Server from dietpi-software?

Because for me this is working fine as I’m writing this post on a DietPi Desktop using xRDP and TigerVNC Server. :sunglasses:

The screenshot is kind of useless for this issue since it just shows my deskop but it is attached. I can move my cursor but I can’t interact with anything either by clicking or using my keyboard, i.e. I can look but not do.

I installed it through the dietpi-software. Only thing extra I had to do was install xorgxrdp for it to work. Otherwise, I just got a blank screen which would launch the desktop on the external display for some reason (couldn’t interact over there whatsoever).

what did you installed exactly ?? I just installed TigerVNC Server from dietpi-software and on to the xrdp package using apt-get

XRDP was installed w/ dietpi-software which also installed TigerVNC alongside it. Only thing installed using apt-get was the xorgxrdp.

I did it now more than once. i just selected xrdp from dietpi-software and it was working out of the box on my VM. nothing to install in addition. no additional packages needed. Will try it on my RPi3B later the weekend as soon as my SETI@Home calculations finished.

Managed to get this working… somehow. I removed everything related to it, including the other manually installed packages from apt-get, and now it works when I use Xvnc as the domain.

yep indeed you would need to use Xvnc as domain.

Indeed the missing mouse and keyboard support is something that we couldn’t fix with xrdp without VNC. Since stretch there is the separate xorgxrdp package which should enable it but last time I tested it, it didn’t work, along with some other issues with the stable xrdp package on stretch, which is why we pull it from backports there. So for now VNC server and hence Xvnc connection type is required as mentioned in our online docs: https://dietpi.com/forum/t/dietpi-software-details-for-all-installation-options/22/64

Also see my testing effort on this case: https://github.com/MichaIng/DietPi/issues/3022

And btw, if you have any chance to use VNC directly (there are plenty of little efficient open source clients available for Windows) and skip xrdp, do that: The desktop will behave much more responsive.

Thanks MichaIng for that information. Missed that. I might check into that but I am lazy and like using Bitvise for an all-in-one SSH, SFTP, and RDP. Maybe I’ll try MobaXterm again some day for VNC.

And thanks Joulinar for your assistance in trying to figure it out as well.