XRDP not working with Windows Remote Desktop

I’ve installed XRDP (my SBC is odroid C1+) and when I try to use Windows Remote Desktop I’m getting a vague “error - problem connecting” error. See attached screenshot. I’ve tried different desktops to no avail. I’m using module: sesman-Xvnc.

Any ideas as to what I’m doing wrong?

SOLVED. I uninstalled xrdp, then installed TightVNC, then xrdp. It seems it’s a prerequisite? How do I let the devs know about this?

Hi,

Thanks for the report, we’ll run tests and investigate:
https://github.com/Fourdee/DietPi/issues/1071

I tried the fix and still cannot get in. I uninstalled both xrdp and TightVNC. Then installed TightVNC and after the reboot I installed xrdp. I still get the login error. Any ideas? Thanks!!

Hi,

I’ve just tested Odroid C2 with Jessie and a fresh install of XRDP. No additional VNC software is required.

Sesman-Xvnc is required as Xorg module is not available on Jessie (AFAIK):

@dirtyharrywk

Please can you confirm device used?

I made a mistake. I was using the wrong user name. Thanks

I make a fresh install recently of latest diepi but I can’t connect to it using RDP. On older diepi 159 I was using xrdp and MATE and it was wokin ok, but now I am gattin these errors in file xrdp.log

[DEBUG] xrdp_00000b39_wm_login_mode_event_00000001
[20180327-10:20:15] [INFO ] Loading keymap file /etc/xrdp/km-00000410.ini
[20180327-10:20:15] [WARN ] local keymap file for 0x00000410 found and doesn’t match built in keymap, using local keymap file
[20180327-10:20:31] [DEBUG] xrdp_wm_log_msg: connecting to sesman ip 127.0.0.1 port 3350
[20180327-10:20:35] [DEBUG] Closed socket 16 (AF_INET6 :: port 50918)

In fact I don’t see anything on port 3350. I think I am missing somethig…

Yeah that would be one beginner question if XRDP is installed on default?

I cannot connect to my rpi via remotedekstop from windows to it :-/

Do i need to add it?

DietPi is offering xrdp as software package within our catalogue. No need to do manual installations.

1 Like

Ok, Joulinar, maybe my memories were wrong, I did this few times on Ubuntu, Fedora and raspberry, unfortunately without documenting it exactly.

So it can be that I just use your automated script! Perfect script then, I think on other machines I had more trouble. Sorry I deleted my “memories” entry with bullshit info…