XLink Kai Support

I’m trying to use my DietPi (Raspberry Pi 3b) as an XLink Kai server. This allows for video games that support LAN mode to be played with others over the internet. It works on many consoles. I went through their install instructions, but the “kaiengine” app fails to run for me.


There is another project that is a dedicated image and/or install script that enables XLink Kai on a Raspberry Pi, but it comes with many other services that I’m not planning to use and it also only connects to the internet over wifi and dedicates the Pi ethernet port to a single console (directly connected). https://github.com/toolboc/psx-pi-smbshare

Here’s the error I get after trying the teamxlink install guide:

dietpi@DietPi:~$ sudo kaiengine
XLink Kai v7.4.39 build 539601671 Linux ARMHF Package (c) 2020 Team XLink  https://www.teamxlink.co.uk/

Config file: /etc/kaiengine.conf
Web interface is ready, connect to:
Downloading language file en.xml
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::system::system_error> >'
  what():  resolve: Service not found

Some things I’m running on DietPi:

  • NextCloud

  • Plex Media Server

  • PiHole

  • Syncthing

  • lighttpd

  • mariadb

  • php 7.3

  • redis-server

I’d be happy to provide troubleshooting and testing if this is something that might be considered for adding to the available software packages. Thanks for reading!


many thanks for your message. Probably it would make more sense to ask on a XLink specilized Board https://www.teamxlink.co.uk/forum/

I see one error message but I’m not sure what is meant by related to kaiengine

  what():  resolve: Service not found

So probably guys on XLink Board knows where to look into

Thanks for the quick reply. In the Pi specific XLInk support channel on their discord, they seemed to think it was DNS related. I thought DietPi might be doing some fancy DNS workarounds to allow multiple server softwares to run in tandem (like what allows Nextcloud in a sub-directory while pihole runs from the root directory). I’ll make a more formal post in their forums.

well DNS has nothing to do with the setup of web server directories. Btw is quite normal to use sub directories on a web server. Next to this PiHole is located on a sub directory (/var/www/admin) as well. There is nothing special on DNS settings following Debian settings.

Thanks for clarifying. That makes sense to me now that it would not specifically be a DNS issue. To provide additional insight, I just burned a clean DietPi OS and booted up, ran the Kai installer, and get the same error. I’ll try now on a standard Raspberry PI (lite) OS to see if I have the same result or if things work. Then at least I’ll know if it’s a difference in the default OS capabilities.

Can confirm that the installation and running the kaiengine app works on the Raspberry Pi (lite) OS.

Just to avoid any misunderstanding. DietPi is not an own OS. It’s a set of scripts on top of a Debian base image. In case of Raspberry Pi SBC, Raspberry OS is used. Means DietPi is an extrem slim / diet version of Raspberry OS with some scripting on top. If you application is not working, there might be some packages missing that would be needed by XLink Kai

I understand, but you put it much more eloquently. I’ll explore what might be missing. Still I’ll leave the request for XLink to be an installable software in DietPi. It would be handy and would also be nice if it were run as a service.