XFCE4 issues - Pine 64+


Well - I’ve got DietPI up and running on my Pine 64+ (2 GB model with WiFi/BT) - and I must say I’m impressed. Seems quicker and more stable than the Debian install from Pine themselves, I’m running it on one of my Motorola Lapdocks…

However got a few teething troubles :

  1. The default “terminal emulation” app is “vanilla” xterm - and has no configuration options, I know there’s a config file somewhere - but - I want transparency and menus to change font size (I have poor eyesight). I’ve installed both “gnome-terminal” and “xfce4-terminal” via apt-get - the apt-get “seems” to be successful, but there’s NO “xfce4-terminal” or “gnome-terminal” binaries anywhere on the system!

  2. WiFi - I’ve installed network-manager via apt-get - and sure it’s there and installed - but there’s no options in xfce4 to configure - I’ve got a “known” connection for my work’s “corporate” wifi (PEAP/EAP WPA2) - placed it in /etc/Network-Manager/system-connections/ - but it won’t join (I edited with the MAC address of wlan1 as reported by “ifconfig” as root).

I’m running the latest DietPI - 131…
— edit —
Well what do you know?!?

Somehow or other - third time lucky? Replaced “xterm” with “xfc4-terminal” and it runs like a dream!

Then - I’d previously ignored something I’d posted in another forum about saved Network-Manager configs for SSIDs…

Must be owned by root with “0600” attributes… reboot - and I’m online!!!
— edit 2 —
I’ve noticed that /boot/uEnv.txt is getting overwritten at every boot… I just tried hard-coding MAC address in there - doesn’t stay…
— edit 3 —
Unable to get firefox-esr / iceweasel to run - “Segmentation fault”…

Now I’m having trouble with web-browsers…

Can’t get chromium to install from an arm64 deb file (people on Pine64 forum have gotten it to work in debian and arch : http://forum.pine64.org/showthread.php?tid=688 )…

Can’t get firefox to run… I’ve uninstalled re-installed - same thing - no diagnostics if I hit a menu icon, “Segmentation fault” if I try to run it from an x terminal on the XFCE4 desktop…

Midori installs and runs - but I kinda hate midori…

surf works - and works with “tabbed” - but I don’t want to have to type a URL everytime I want to go to a specific page…

“epiphany-browser” (“web”) installed - but just kinda displays a “bar” and application title-bar, never responds, I never get an address field to type URL’s into…

qutebrowser has issues installing (I got it from here : https://github.com/The-Compiler/qutebrowser/releases)…

I’ve used it on CHIP before - and it’s “okay” (better than midori)… I could handle using qutebrowser if I could get it to work - I’m comfortable with vi/vim navigation keys…

I kinda HATE using the Pine64 forum - one of their admins is whiny namby-pamby little prima-donna - always butting in to conversations with the wrong information! I’ve seen him wrong several times - but won’t admit it - and the site owners don’t police him… thinks an answer to not getting HDMI / LCD working is to install and run VNC - FFS! I know that! But it’s NOT the answer! That’s not a “fix” or a solution - it’s a “kludge”… and that admin is the KLUDGEMEISTER!


I’ll look into these, see what we can do :slight_smile:
XFCE4-term should be installed by default. So i’ll check that.

WiFi - I’ve installed network-manager via apt-get -

Its worth noting, DietPi has a lightweight program to setup your WiFi adapters. Simply run dietpi-config from the terminal, or under system menu. Then enter the Networking options menu.
As you now have Network-Manager installed, probably best to stick with that :slight_smile:

I’ve noticed that /boot/uEnv.txt is getting overwritten at every boot… I just tried hard-coding MAC address in there - doesn’t stay…

DietPi creates a RAMdisk during boot for common files. You’ll need to edit it from /DietPi/uEnv.txt.

I kinda HATE using the Pine64 forum - one of their admins is whiny namby-pamby little prima-donna - always butting in to conversations with the wrong information

Yep, know the feeling.

I tend to ignore those forums and just get on with working on DietPi. Its like a childish pissing contest to see who has the biggest ego and knowledge.
The funny thing is, most of the time they dont like sharing their knowledge (if it exists), instead, resulting in childish “your wrong”, “Don’t do it that way” with no reason why or even a method for the “best/correct way”. So kind of useless and pointless lol.

Saying that, even I get things wrong sometimes :wink:

Got Chromium working on XFCE4 and Pine A64 based on this guide, i’ve hosted the binaries on dietpi.com (the ones in the guide are no longer available).

Run the following commands to install it.

wget http://dietpi.com/downloads/binaries/all/chromium_52.0.2743.116-1-deb8u1.1_arm64.deb -O package.deb
dpkg -i package.deb

apt-get install -f -y

wget http://dietpi.com/downloads/binaries/all/chromium-l10n_52.0.2743.116-1-deb8u1.1_all.deb -O package.deb
dpkg -i package.deb

wget http://dietpi.com/downloads/binaries/all/chromedriver_52.0.2743.116-1-deb8u1.1_arm64.deb -O package.deb
dpkg -i package.deb

#Allow root, egl and disable sandbox (blank screen without)
sed -i '/Exec=/c\Exec=chromium --disable-seccomp-filter-sandbox --use-gl=egl --user-data-dir --temp-profile' /usr/share/applications/chromium.desktop

Now you can run chromium from application menu > internet

Thanks so much for your help! Following that guide now (and your installation steps!)!

Thanks mate!

I’d also REALLY like to get qutebrowser running on here - will keep trying…


I’ve got this page open in Chromium in DietPI on my Pine64 + and using Synergy KVM from my Thinkpad to control it!

And Chromium is actually “usable” on this hardware / system (I’ve got 8 tabs open!)… I’ve tried it on my BananaPI running Armbian, it was all but unusable - and forget about using it on NTC CHIP!

Regarding NetworkManager above - I kinda prefer to use that - VS the dietpi-config scripts… e.g. I was unable to get it to connect to my work’s “corporate” PEAP/LEAP SSID… but using NetworkManager and an SSID config file in /etc/NetworkManager/system-connections - I was able to connect…

Anyway - I’d just like to say thanks for such an awesome software build for the Pine64! Streets ahead of anything at Pine64.pro… Not disparaging the guys who are working on the Linux builds for Pine - but it would be nice if the actual company that sold them would put some $$$ in and hire an actual full time kernel hacker!
— edit —
I forgot to give you DietPI people another pat on the back! It took me ages to figure out how to run Pine off a battery (the prima-donna admin over there at the Pine Forume gave me the COMPLETELY wrong information, and also said I needed a power switch to run a battery) - anyway - running the Longsleep build of Debian XFCE for Pine - a 2500 mAh battery was not enough to keep Pine up during either leg of my daily commute - but with DietPI it easily makes it - and more! Today it stayed up for about 1.5 hours running on battery only!

Now - also - if I had Mali GPU drivers going on this thing - it would be awesome!

Kudos to you guys!

Update : I got qutebrowser up and running… It’s minimalist approach actually looks more “modern” than chromium…

I use network manager in Diet Pi Xfce.
Simply edit the /etc/network/interfaces file and delete everything under #Ethernet and #Wifi. After rebooting already controls the connections through network manager and its applet in the panel.

Thats fine, but just bear in mind, switing to network-manager will break DietPi’s lightweight networking system in:

  • dietpi-config > networking options: adapters