X86 DietPi Dashboard wrong temp shown

Creating a bug report/issue

I have searched the existing open and closed issues, none for this version of DietPi.

Required Information

  • DietPi version | G_DIETPI_VERSION_CORE=9:

  • Distro version | bookworm

  • Kernel version | 1 SMP PREEMPT_DYNAMIC Debian 6.1.76-1 (2024-02-01) x86_64 GNU/Linux

  • Architecture |amd64

  • SBC model | Native PC (x86_64)

  • Power supply used |NA

  • SD card used | NA

Additional Information (if applicable)

  • Software title | (Dietpi Dashboard

Steps to reproduce

Open Dietpi Dashboard its shows incorrect temperature

Expected behaviour

cpu shows this
─────────────────────────────────────────────────────
DietPi v9.0.2 : 18:56 - Mon 02/19/24
─────────────────────────────────────────────────────

  • Device model : Native PC (x86_64)
  • CPU temp : 52 °C / 125 °F : Running warm, but safe
  • LAN IP : 192.168.5.234 (eth0)
  • MOTD : DietPi v9.0 has been released. Check out all changes:
    v9.0 January 2024 - DietPi.com Docs

Actual behaviour

Extra details

better to report this directly to the DietPi Dashboard Github. GitHub - ravenclaw900/DietPi-Dashboard: A lightweight, standalone web dashboard for DietPi

Not much we can do within the forum on it

I had similar problems in x86_64. install lm-sensors and run sensors detect
Let it run through, just keep hitting y
Change htop config to show temp, or install bpytop.
The cpu frequency and temperatures should be correctly picked up.
I also use neofetch that seems to be correct too.

Will try that, thans @Darron

1 Like