Wyze Webcam Rock64 Octoprint

Hi folks! New to dietpi so bear with me. Was using a raspberry pi3b+ with octopi for my 3d printers. Since pi’s are in short supply and I need to recover them to use for something else I decided to replace them with Rock64’s and dietpi with octoprint. Everything went well with the switchover except the webcam to monitor my printing through octoprint. I had been using a wyze cam v2 running the webcam firmware and it worked flawlessly with the pi3b+ and octopi. Dietpi on the Rock64 won’t even acknowledge that it is connected. When I run lsusb it does not see anything for the webcam. I have tried a different webcam and it does come up when I run lsusb and I have been able to get it to work with mjpg-streamer no problem. So I guess I am asking any ideas what would be causing that wyze webcam to not show up? Would it be a driver issue of some kind? I know the simple answer is to use a different webcam but I have mounts made for the wyze already attached and setup on the 3d printers already so I would really like to use them.

Thank you,


Creating a bug report/issue

Required Information

  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname -a
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
  • Power supply used | (EG: 5V 1A RAVpower)
  • SD card used | (EG: SanDisk ultra)

Additional Information (if applicable)

  • Software title | (EG: Nextcloud)
  • Was the software title installed freshly or updated/migrated?
  • Can this issue be replicated on a fresh installation of DietPi?
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

Expected behaviour

Actual behaviour

Extra details