Wrong SSH password after update from 158 to 159


I just did something you should never do on my XU4 system
I updated a running system :blush: from 158 to 159

Now I cant login via WinSCP nor with Putty.
It asks for user, so “root”
But then it doesn’t take the standard “dietpi” passoword.

Didn’t change anything else.
Any tipps?


Just tried user “dietpi” instead of “root” with password “dietpi” and i am in.

On the changelog page in the picture the user root is still seen.

So what gives?


Merry xmas for everyone :smiley:

Ok, solved myself .
I used dietpi-config with sudo under user dietpi login to change the root password to dietpi again.

Worked out.

Jeez that was a xmas heart attack, almost.



Hmm … how have you trigger this update?

dietpi@DietPi:~$ sudo dietpi-update


Hi k-plan,

yes as you mentioned

dietpi@DietPi:~$ sudo dietpi-update

without the sudo as I always login as root.

My fix was not persistant as after reboot it was gone again. I am not sure as it could also be a problem with my ssh connaction PC wise.
What I did to finally solve this was:

Restored my Backup (taken just before update)
The fault was still there but I was on 158 again.
Reversed the SSH Server back to Dropbear via Dietpi menues
Then the root login was already working, also after power reset and reboot
Re-installed SSH Server and from that point on it was ok.

When changing from/to dropbear and back I realized that my putty was asking for an update of the keys. maybe there was something messed up as it didn’t ask for an update after I did the 159 Update.
It also asked for it when logging in as dietpi user, so I asume thats why this one worked.

Next time I try to look for an forced key update from putty or WinSCP, but for now I keep it as is :rofl: