WordPress missing MySQL extension for PHP?

Hey there,

Deciding that I’d like to host my own, I ran through the dietpi-software install of both WordPress and Image Gallery. Browsing to my Pi/wordpress though doesn’t seem to work. It tells me: Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

However, browsing to phpinfo.php does seem to show it’s there. I’m also running Subsonic 6 and Pi-Hole without issues, though unsure if either of them need/use PHP anywhere.

The installation of WordPress didn’t give me any errors, and rebooted the Pi at the end as it was supposed to. Any ideas? :slight_smile: Thanks!

Works now. It appears that php5-mysql wasn’t installed originally. Installed phpMyAdmin as well and that came along with it, now WordPress launches correctly.


Thanks for the report.
I believe i’ve found the cause for this, will be resolved for next update v140.

Just to confirm, so I can run test, which webserver choice are you using (eg: Lighttpd/Nginx/Apache2)?

Thanks! I’m running with lighttpd at the moment. Still debating if I’ll switch to another one, but so far it seems to be doing what it needs to.