Wordpress issue - help please


This is the page that I get instead of my Wordpress site when I type my domain as "<www.mysite. ". If I type “<www.mysite./wordpress>” this works on my LAN but not outside of my network on the Internet (I have a static ip and DNS forwarded to port 80 via NameCheap).

I installed Wordpress via “dietpi-software” script, which works very well and uses lighttpd.

I’m really stuck with this install and after 3 days trying.

Any help very much appreciated. Thank you.

Hi,

pls can you stop recreating the topic again and again and again. This is now the 3rd or 4th time your have open the same while deleting the old one. thx

Apologies - I’m new to this and struggling. I was trying to put examples of www of my site without actually linking to the web but didn’t get it right, so tried to delete and rewrite more than once - sorry.

Hi,

basically you can adjust your post. No need to delete and recreate. Back to your topic. Did you adjusted WP settings WordPress Address (URL) as well as Site Address (URL) pointing to our DDNS?

On my test this was needed to get WP reachable from internet.

Many thanks. This worked and to add you need to copy index.php to www (root).

usually moving index.php should not be needed

No, don’t move index.php please copy to root (www) and leave copy of index.php in subdomain (wordpress). Change the following and save the index.php file in root. Change the line that says:require( dirname( FILE ) . ‘/wp-blog-header.php’ );to the following, using your directory name for the WordPress core files:require( dirname( FILE ) . ‘/wordpress/wp-blog-header.php’ );
Don’t edit the copy of index.php in wordpress subdomain.
Delete index.lighttpd.html from root to remove landing page.
Wordpress settings: change site url to yourwebite(.com)

For full instructions: https://wordpress.org/support/article/giving-wordpress-its-own-directory/

1 Like

Had this working for some time, but after a failure with the drive was trying to set this up again.

I moved the index.php file to the root and changed the line stated above. Removed the other index.html file for Apache.
Then went on to the linked site and followed the linked Wordpress site. I let WordPress use pretty permalinks, and saved the created .htaccess-file. Nothing seems to work