wlan0 vanished along with nl80211 after apt-get upgrade

I thought about updating my packages and after doing apt-get update I ran apt-get upgrade, that’s it. It booted fine but there was no wlan0 interface. I tried “wpa_supplicant -B -D nl80211 -i wlan0 -c /etc/wpa_supplicant/wpa-supplicant.conf” and it says “nl80211 generic netlink not found”.

How could’ve this happened? Everything was working fine before but after the upgrade that nl80211 driver is missing. What should I do?

Which SBC, DietPi and Debian version are you using?

And please show the following:

journalctl -u ifup@wlan0
dmesg -l emerg,alert,crit,err
ip l

I am using debian 10 buster on raspberry pi 3b+, with dietpi version being 6.33.3

Journalctl command says no entries
dmesg command doesn’t output anything
ip command lists “lo” and “eth0” interface, no wlan0

So indeed the kernel does not recognised the adapter anymore. No output of dmesg -l emerg,alert,crit,err? Wow, 99% of RPis at least show something related to GPU memory and/or drive cache :slight_smile:.

It means you have no network on that system currently, hence a dietpi-bugreport upload does not work, right?

Let’s see the whole kernel log then. Feel free to mask any personal/identifying stuff inside, like hostnames, UUIDs or so: dmesg

I think issue could definitely be that missing driver. Although I don’t know much about this stuff. Maybe apt upgrade updated the kernel too.
dietpilog.txt (18.5 KB)


can you check in dietpi-config > 7 : Network Options: Adapters if Onboard WiFi is/was set to ON??

Yeah I’ve checked that already and even toggled it off and on and did some reboots, that made no difference either.

I think I’ve found the problem. I keep 2 “boot” partitions, one on memory card and other on first partition of usb that carries rest of the system in second partition. I do that to ensure sudden power cut off won’t make it unbootable as it has happened in the past, and that I won’t have to wait extra 8 seconds for bootup to begin, which you have to while booting from usb.

Now after bootup, memory card gets unmounted and the first boot partition on usb gets mounted on /boot.

So I am assuming “apt-get upgrade” updated the kernel on /boot and removed unnecessary stuff from rest of the os (because I somehow gained 11mb after updating :smiley:), which then led to nl80211 getting removed from os because maybe newer kernel already has it built-in. And since I am booting from old kernel, it’s not being able to find that driver. These are just some wild guesses.

But the bottom line is that if I just remove my memory card and boot just from usb, everything works fine, except that my /etc/wpa_supplicant/wpa_supplicant.conf file has been wiped. No biggie. I’ll just copy working boot partition to memory card and I’m good to go.

Thanks for the help guys :slight_smile:
dietpilog2.txt (22.2 KB)

quite a complex setup.

Yesterday I moved my RPi3B+ from SD card to boot fully from USB. Comparing boot times, it’s nearly same or even faster.

No I am talking about the time it takes for bootup to begin, because if you have no sd card and some OTP set, it will wait at least 6-7 seconds before it begins booting from usb

I was talking about end-to-end boot time. From power on until login reached. But need to say that I’m using DHCP. On SD card this is taking time while booting from USB seems to be faster. Maybe I will do a comparison later the evening.