Wireguard not being available on software list

What is this for a device and kernel 5.10.100-ti-r37? I’m not sure whether a compressed kernel driver can be loaded by the system, i.e. whether modprobe wireguard works without first uncompressing that driver:

apt install xz-utils
xz -d /lib/modules/5.10.100-ti-r37/kernel/drivers/net/wireguard/wireguard.ko.xz

If modprobe however succeeds without this, we may relax our check to allow a compressed driver. Another question would then be whether *.gz and other formats are supported as well, and whether this is kernel specific or works on all devices :thinking:.


Checking DNS resolver                                                        │
│  - Command: ping -nc 1 -W 10 dns9.quad9.net                                  │
│  - Exit code: 1                                                              │
│  - DietPi version: v8.2.2 (MichaIng/beta) | HW_MODEL: 22 | HW_ARCH: 2 |      │
│ DISTRO: 6                                                                    │
│  - Image creator: me                                               │
│  - Pre-image: debian 11                                                      │
│  - Error log:                                                                │
│ PING dns9.quad9.net(2620:fe::9) 56 data bytes                                │
│                                                                              │
│ --- dns9.quad9.net ping statistics ---                                       │
│ 1 packets transmitted, 0 received, 100% packet loss, time 0ms                │
│                                                                              │
│      Retry          : Re-run the last command that failed                    │
│      DietPi-Config  : Edit network, APT/NTP mirror settings etc              │
│      Open subshell  : Open a subshell to investigate or solve the issue      │
│                     ●─ Devs only ─────────────────────────────────────●      │
│      Change command : Adjust and rerun the command                           │

Please do not mix topics. The original issue was that WireGuard was not shown in the software list since the kernel module is shipped compressed. Please see whether it can be modprobe’d and if not, whether it can be modprobe’d after being decompressed, with the commands above. That your network check fails when using WireGuard as client may even be related to the fact that it does not work as expected with the compressed module. So let’s verify that first.

sorry, i’ve replied to this message with previous one

Try to disable IPv6 on network settings as it seems not working correctly

Btw: do you use Wireguard as client or server?

Ah sorry, it is then provably already a prove that it works with the compressed driver, as the IP ping succeeded. Indeed try to disable IPv6, if that is not done by the WireGuard client config already. Most VPN providers do not support IPv6.

From above post, WireGuard is used as client.

The logs may help as well:

journalctl -u wg-quick@wg0

This works if the client config is /etc/wireguard/wg0.conf (else rename the wg-quick appendix) and started with wg-quick@wg0.service accordingly.

I use wireguard as a client and with the fixes you suggested everything is working fine now

yes usually public VPN provider offer IPv4 only. Therefore disabling IPv6 fixed it :sunglasses: