Wireguard install failed, now can't do anything else with dietpi-software

Creating a bug report/issue

Required Information

  • DietPi version | 8.11.2
  • Distro version | bullseye
  • Kernel version | Linux DietPi 4.14.294+
  • SBC model | Odroid HC2
  • Power supply used | 12V 5A from Odroid
  • SD card used | Sandisk Extreme

Additional Information (if applicable)

  • Software title | Wireguard
  • Was the software title installed freshly or updated/migrated? Freshly
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | 82814656-605d-4288-b79f-8eb9e4002d32

Steps to reproduce

  1. I tried installing Wireguard from dietpi-software, the install failed, I did not pay much attention to the error as I was just wanting to experiment with Wireguard and don’t need it.
  2. Since the failure, I can’t install or uninstall anything else from dietpi-software, or run ‘apt upgrade’, instead I get an error that seems to relate to trouble removing old Wireguard files.

Extra details

The error:

│ APT install for: linux-image-4.14-armhf-odroid-xu4 linux-headers-4.14-armhf-odroid-xu4    
     │  - Command: apt-get -y --allow-change-held-packages install linux-image-4.14-armhf-odroid-xu4                          
     │ linux-headers-4.14-armhf-odroid-xu4                                                                                    
     │  - Exit code: 100                                                                                                      
     │  - DietPi version: v8.11.2 (MichaIng/master) | HW_MODEL: 11 | HW_ARCH: 2 | DISTRO: 6                                   
     │  - Image creator: DietPi Core Team                                                                                     
     │  - Pre-image: Meveric                                                                                                  
     │  - Error log:                                                                                                          
     │ Reading package lists...                                                                                               
     │ Building dependency tree...                                                                                            
     │ Reading state information...                                                                                           
     │ linux-headers-4.14-armhf-odroid-xu4 is already the newest version (4.14.294-1).                                        
     │ linux-image-4.14-armhf-odroid-xu4 is already the newest version (4.14.294-1).                                          
     │ 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.                                                         
     │ 1 not fully installed or removed.                                                                                      
     │ After this operation, 0 B of additional disk space will be used.                                                       
     │ Setting up wireguard-dkms (1.0.20210219-1) ...^M                                                                       
     │ Removing old wireguard-1.0.20210219 DKMS files...^M                                                                    
     │ ^M                                                                                                                     
     │ ------------------------------^M                                                                                       
     │ Deleting module version: 1.0.20210219^M                                                                                
     │ completely from the DKMS tree.^M                                                                                       
     │ ------------------------------^M                                                                                       
     │ Done.^M                                                                                                                
     │ Loading new wireguard-1.0.20210219 DKMS files...^M                                                                     
     │ Building for 4.14.294+^M                                                                                               
     │ Building initial module for 4.14.294+^M                                                                                
     │ Error! Bad return status for module build on kernel: 4.14.294+ (armv7l)^M                                              
     │ Consult /var/lib/dkms/wireguard/1.0.20210219/build/make.log for more information.^M                                    
     │ dpkg: error processing package wireguard-dkms (--configure):^M                                                         
     │  installed wireguard-dkms package post-installation script subprocess returned error exit status 10^M                  
     │ Errors were encountered while processing:^M                                                                            
     │  wireguard-dkms^M                                                                                                      
     │ E: Sub-process /usr/bin/dpkg returned an error code (1)

The make.log referenced in that error:
make.log (30.3 KB)

you could try to purge wireguard packages

apt purge wireguard*

Excellent, that did it!

ok good. Question: how you tried to install Wireguard. Did you used dietpi-software or was this a manually installation?

using dietpi-software

Could you have a look on this topic. WireGuard installation failed on a HC2 image running old kernel 4.14.

What does the failed build log say?

cat /var/lib/dkms/wireguard/1.0.20210219/build/make.log

Probably newest WireGuard cannot compile on this old kernel anymore.

@MichaIng log was already attached above

So jep, looks like support has gone. I.e. for using WireGuard, our new image would need to be used. Sadly it isn’t possible to upgrade, since a different partitioning is required for the mainline U-Boot.

I disabled the install option via DKMS now completely. All legacy Odroid vendor kernels are not supported anymore by WireGuard: v8.12 · MichaIng/DietPi@e8a944a · GitHub

EDIT: On x86_64 Buster with Linux 4.19 the build still succeeds. However, there it is much easier to upgrade to Linux 5.10 via backports:

apt install -t buster-backports linux-image-amd64
1 Like

Much appreciated! fortunately I don’t presently have any need for Wireguard on this device, I simply wanted to explore its features. I’m always very impressed with the responsiveness of support with DietPi!