Wifi not working on RPi Zero W

Hello everyone, I am having a weird issue with the RPi Zero W (Board v1.1). First I tried booting up and after couple messages I ended up getting this error : https://imgur.com/a/XZGHVTR

I tried changing the settings to US and also manually putting down the infos. I also tried editing the dietpi.txt file. Same issue, I would really appreciate some help. Thanks!

p.s One thing I have noticed is that, the img file says it is 6.8 but after booting, it says 6.7.

Anyone? I’m hope I’m not the only one with a RPi Zero W :frowning:

Just tested on my RPi Zero W, and it booted and updated without issue, so probably not a problem with dietpi. The error you got was a connection issue, so try pinging a few other sites to make sure it’s not an issue with the board or install. If the sites respond it could have been a temporary issue, so try updating the zero w again. If if still doesn’t work, then try installing another distro and updating.


Please verify WiFi has enough signal strength (dietpi-config). Sounds like its borderline edge of capable range.

Hi Fourdee,
My RPi Zero W is 2 ft away from the router. The weird thing is, I tried with Rasbian Stretch Lite and a separate Octoprint copy, none of them are detecting the Wifi in Zero W. Good news is, DietPi is solid but the bad news is the WiFi of my ZeroW is broken. Any ideas?