Wifi Hotspot

Wifi hotspot doesn’t work any more get error on install

Failed to start hostapd.service: Unit hostapd.service is masked.

No idea what masked it, but simply unmask via: systemctl unmask hostapd.service
Then retry.

Did what you say and my hotspot is back online but no internet connection is posible, even after reinstall on my raspberry pi i did have to do that commandline procedure to activate my hotspot but still no connection for internet. tested raspap on other system on raspberry pi and that worked so u guess that it have to do with some kind of update.

I did install an old image 6.17 on my raspberry pi and get the same error, when i use your command it fixed it, so now i have a connection and internet again, so it must be something in the updates i guess. Hope it stays good for now.

identical trouble afther upgrading from v6.22.3 to v6.24.0 with hostapd, i restored to 6.22.3 again.

Could you try it with the hostapt package from the repo:

apt install --reinstall hostapd

i did apt purge hostapd and then reinstall with apt install, and it stayed the same. so for now am again on v6.22.3 with a backup restore.

Or makes it a difference to use apt install --reinstall hostapd?

I first upgraded to v6.24.1 (maby nothing to do with it i guess).

And then “apt install --reinstall hostapd” did the trick, thx !!!

Again same problem with hostapd, even when i reinstall with the beta version a get the same errors !

Did this actually work any time before with the same WiFi adapter?

Yes, but only after a backup restore, this problem keeps showing up again and again!

Which RPi model do you use?
And which WiFi adapter (if not an internal one): lsusb

In case it is an external USB WiFi dongle, please try the following:

cd /tmp
wget https://dietpi.com/downloads/binaries/all/hostapd_2.5_all.zip
unzip hostapd_2.5_all.zip
rm hostapd_2.5_all.zip

the next depends on RPi and WiFi adapter model :wink:.

It is a RPI 3 B+ that i use.

So the internal WiFi I bet… hmm then I have no idea why it fails currently, the steps I started are then not applicable.

A debug start then:

systemctl status hostapd
systemctl stop hostapd
hostapd /etc/hostapd/hostapd.conf

systemctl status hostapd
● hostapd.service
Loaded: masked (/dev/null; bad)
Active: inactive (dead)

RPI 3 B+
solution ???

i have left my device off yesterday, and tested the steps again today, it is working again.

So don’t know what is the real problem, thx for the info. :sunglasses: