Wifi HotSpot - EW-7811UTC connection issues

I wondered if anyone can help.

I have Wifi HotSpot and Tor installed onto a Pi B+, initially with an Edimax EW-7811Un dongle, which has worked fine. I’ve since bought an upgraded Edimax EW-7811UTC 5Ghz dongle as the signal in my home isn’t great and I thought this would help. I’ve checked and it is compatible with the Pi B+. Anyway, after installing the correct drivers for the EW-7811UTC for the kernel at the time, my Hotspot was being broadcasted and everything appeared to be ok. But when I tried to connect any devices to it, I’d get the error message ‘Can’t connect to this network’.

So, I did an rpi-update, which has upgraded the kernel, so I also updated to the new EW-7811UTC driver, using the following in SSH:

wget https://dl.dropboxusercontent.com/u/80256631/8812au-4.1.21-872.tar.gz
tar xzf 8812au-4.1.21-872.tar.gz

However, I’m still getting the same issue. But when I go back to using the older EW-7811Un dongle, everything is working ok and I can connect to all my devices again.

I’ve even done a complete clean reinstall of the DietPi image and only used the newer EW-7811UTC dongle incase there was some kind of conflict with the older EW-7811Un driver, but still get the same issue.

Has anyone else had this problem and managed to solve it?