WiFi adapter turns off after shutdown/reboot

Hello, I setup my Pine A64+ on the latest version of DietPi over Ethernet SSH. I am now trying to switch from Ethernet to WiFi. I have both modules activated in dietpi-config and they are both connected.

I then run ifdown eth0 to stop the Ethernet, unplug the ethernet cable, and switch over to the WiFi’s IP on SSH and it connects. When I connect it is running on wlan0 and the Internet Test works.

I then reboot to make sure everything will work but now it won’t connect. I replug my ethernet cable back in and my WiFi adapter is turned off / says Not Found. I did this a couple times now and it seems that reboots and shutdowns turn off my WiFi adapter.

Please help, thanks!

Also, the only way to access my Pine A64 is through SSH because their is no video output. I have tried many HDMI cables, monitors, and TVs. No success.

Other people on these forums also say this version does not support video output. I have tried version 1.44 and the video output works on that one.

Help Fourdee