when adding NFS Qnap the system freezes

Hello,

This is my first post here, I am writing to you because I need help.

I have a QNAP NAS. I am trying to add it to DietPi through the Manager. The system stays like this, it was for hours and does not advance

[ INFO ] DietPi-Drive_Manager | Checking for required APT packages: nfs-common netbase
[  OK  ] DietPi-Drive_Manager | Desired setting in /boot/dietpi/.installed was already set: aSOFTWARE_INSTALL_STATE[110]=2
[  OK  ] DietPi-Drive_Manager | rmdir --ignore-fail-on-non-empty /mnt/nfs_client
[ INFO ] DietPi-Drive_Manager | Scanning for NFS exports by: 192.168.0.23
 NB: If the server cannot be reached correctly, this may take up to 90 seconds before it times out.
[  OK  ] DietPi-Drive_Manager | mkdir /mnt/nfs_client

I have tried with a command mount -t nfs -o nfsvers=4 192.168.0.23:/downloads /mnt/nfs_client/ and it does mount it.

But every time I reboot the drive disappears. I wish this didn’t happen.

Thank you,

Hi,

yes we have seen this behaviour 2 times already and it seems quite specific to QNAP not working together with latest Linux 5.15 kernel version.

You basically have 2 options.

  1. downgrade kernel to a version before 5.15
  2. create the entry within /etc/fstab manually

Currently drive_manager is not able to deal with this. https://github.com/MichaIng/DietPi/issues/5358

Hi!

Thank you very much for responding so quickly.

I am quite new in this world, could you tell me how to do any of these 2 options?

Thank you,

I would not recommend option 1 if you don’t know what you are doing. Let’s add the mount information manually to /etc/fstab

mkdir /mnt/nfs_client/
nano /etc/fstab

add following into # NETWORK section

192.168.0.23:/downloads /mnt/nfs_client/ nfs nofail,noauto,x-systemd.automount,nfsvers=4

once done, leave the editor and:

reboot
cd /mnt/nfs_client/
ls -la *

Hello,

I have mounted it as it told me, but when I try to access it it stays like this:
root@DietPi:~# cd /mnt/nfs_client/
root@DietPi:/mnt/nfs_client# ls
downloads
root@DietPi:/mnt/nfs_client# cd downloads/

It doesn’t go beyond that line.

Thank you,

can you share

showmount -e
nfsstat -m
df -h

Hello,

Everything is already solved, I had not added a label.

Thank you very much for your help!

Greetings,

what do you mean by “adding a lable” :thinking:

I had not added nfsvers=4 , that’s why it didn’t work

This is not a label, this is an option specifying the NFS version and the most important part to fix it :slight_smile:

Sorry I don’t know much about this. I appreciate a lot your help

Hi,

I have just come across the same problem.

I have created /mnt/nfs_client, added the line to fstab (with my QNAP’s IP address), performed a reboot , but I cannot cd into the directory. I can see it’s there, but I get no such device when I try and cd into it.

showmount -e
nfsstat -m
df -h

gives me…

clnt_create: RPC: Program not registered
Filesystem      Size  Used Avail Use% Mounted on
/dev/root       220G  6.9G  205G   4% /
devtmpfs        916M     0  916M   0% /dev
tmpfs           950M     0  950M   0% /dev/shm
tmpfs           380M  5.5M  375M   2% /run
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           1.0G     0  1.0G   0% /tmp
tmpfs            50M  8.0K   50M   1% /var/log
/dev/sda1       127M   35M   92M  28% /boot
overlay         220G  6.9G  205G   4% /mnt/dietpi_userdata/docker-data/overlay2/db32c3de9435d9a07e151cd3e08f9c7b5fc8111ce301f739a57764542b8bb460/merged

Any advice would be appreciated.

edit: Just spotted an error in my fstab entry. I didn’t update /downloads so just retrying that now…

edit: yep, that did it. The results of ls -lare:

root@DietPi:/mnt/nfs_client# ls -l
total 4
drwxrwx--- 2 root root 4096 May  7 11:51 @Recycle
root@DietPi:/mnt/nfs_client#

Means it is working now?

yes! :slight_smile:

…this thread helped a lot - thanks so much!