Wheezy | Let's Encrypt not working!

Hi,

I am on v103 Wheezy. I did a clean image install on my test sdcard.

I installed LASP Stack and Lets Encrypt via dietpi-software.

The Let’s Encrypt installation did finish without any errors after all but THIS is where the installation process did freeze for about 7 minutes.

After the Lets Encrypt installation i ran the new dietpi-letsencrypt command and THIS was the result.

All of this was done on a super fresh dietpi v103 installation with zero modifications.

How should i proceed?

Regards

Hi Zombie,

I can confirm Lets Encrypt is fully functional on Debian Jessie.

The lets encrypt project is still currently in beta, so the issues you experienced may be related to that. I’ll run some tests on Wheezy and see if I can find a resolution. I’ll let you know what I find.

Ok, replicated the same issue on my Wheezy install.

Ticket: https://github.com/Fourdee/DietPi/issues/141

Appears Letsencrypt-auto is installing Python 2.7 and causes InsecurePlatformWarning: https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning

Updating letsencrypt and virtual environment dependencies...../root/.local/share                                          /letsencrypt/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/url                                          lib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not a                                          vailable. This prevents urllib3 from configuring SSL appropriately and may cause                                           certain SSL connections to fail. For more information, see https://urllib3.read                                          thedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
./root/.local/share/letsencrypt/local/lib/python2.7/site-packages/pip/_vendor/re                                          quests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLCont                                          ext object is not available. This prevents urllib3 from configuring SSL appropri                                          ately and may cause certain SSL connections to fail. For more information, see h                                          ttps://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning

So i removed Python2.7 and manually installed Python3:

apt-get purge python2.7*
apt-get install python3 python3-dev

Which results in:

Cannot find any Pythons... please install one!
./letsencrypt-auto: 103: [: Illegal number: 1:
./letsencrypt-auto: 105: [: Illegal number: 1:
Updating letsencrypt and virtual environment dependencies...Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Traceback (most recent call last):
  File "/root/.local/share/letsencrypt/bin/pip", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 17, in <module>
    from __future__ import absolute_import
ImportError: No module named __future__

I’ll have to disable the Lets Encrypt installation option on Wheezy. At least until a fix, or workaround can be found.

Ok. No Problem. I hope the Lets Encrypt Team still care about wheezy.

THIS is what i have been working with for a while now and it works just fine.

Interesting, thanks for the info.

I’ve left the documentation for setting up a SSL cert in a similar method:
Optional - Alternative Enable SSL (https):I believe this is pretty much the same as your method? To be used on a fresh install of LAMP/LASP.